1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

题意:抽象出来就是给你一张图,给你起点终点,着到起点到终点的所有最短路径,每个点上有一个数,代表这个点上的搜救队的数量,要求输出你走过的路径数目和这些最短路径中你能召集到的最大的搜救队的数量。
这个题目需要一个数组存走过的路的数目path,一个数组存每个点的队数team,一个数组用来存走过的路所含的路径和amount,一个数组更新最短的路径dis.

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
int dis[550],vis[550];
int map[550][550];
int teams[550],amount[550],path[550];
int n,m,start,en;
void dijkstra(int s)
{
    dis[s] = 0;
    amount[s] = teams[s];
    vis[s] = 1;
    int k = s;
    while(k!=en)
    {
        for(int i=0; i<n; i++)
        {
            if(!vis[i])
            {
                if(dis[i]>dis[k]+map[k][i])
                {
                    dis[i] = dis[k]+map[k][i];
                    amount[i] = amount[k] + teams[i];
                    path[i] = path[k];
                }
                else if(dis[i]==dis[k]+map[k][i])
                {
                    path[i]+=path[k];
                    if(amount[i]<amount[k]+teams[i])
                    {
                        amount[i]=amount[k]+teams[i];
                    }
                }
            }
        }
        int min = INF;
        for(int i=0; i<n; i++)
        {
            if(!vis[i]&&dis[i]<min)
            {
                min = dis[i];
                k = i;
            }
        }
        vis[k] = 1;
    }
}
int main()
{
    int i,j;
    scanf("%d %d %d %d",&n,&m,&start,&en);
    for( i=0; i<n; i++)
    {
        scanf("%d",&teams[i]);
    }
    for(i=0; i<n; i++)
    {
        path[i] = 1;
        vis[i] = 0;
        dis[i] = INF;
        for(j=0; j<n; j++)
            map[i][j] = INF;
    }

    for(i=0; i<m; i++)
    {
        int a,b,w;
        scanf("%d %d %d",&a,&b,&w);
        map[a][b] = map[b][a] = w;
    }
    dijkstra(start);
    printf("%d %d\n",path[en],amount[en]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值