PAT 1057. Stack (30)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:
Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print “Invalid” instead.
Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid
题意:就是对栈的操作,其中PeekMedian操作是返回到中位数,也就是值的大小在中间位置的数,如果排序好了查找会超时,因此可以使用块查找的方法,将10^5分成100块,每块里面有1000个数,先确定在哪个区间,再去查找就消耗时间少一点。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<stack>
int bucket[1010000],cnt[10100];///cnt存的是第几个区间,bucket存的是区间里面的数的位置(桶排)
int block = 1000;///每个区间大小为1000
using namespace std;
stack<int>s;
int main()
{
    char a[100];
    int k,i,n,p,j;
    scanf("%d",&n);
    memset(cnt,0,sizeof(cnt));
    memset(bucket,0,sizeof(bucket));
    while(n--)
    {
        scanf("%s",a);
        if(strcmp(a,"Pop")==0)
        {
            if(s.size()==0)
                printf("Invalid\n");
            else
            {
                p = s.top();
                s.pop();
                bucket[p]--;///该区间里面的数减少一个
                cnt[p/block]--;///块也更新
                printf("%d\n",p);
            }
        }
        else if(strcmp(a,"Push")==0)
        {
            scanf("%d",&k);
            s.push(k);
            bucket[k]++;
            cnt[k/block]++;///找到该数所在区间,该区间里面的数加一
        }
        else
        {
            if(s.size()==0)
                printf("Invalid\n");
            else
            {
                int mid = s.size();
                if(mid%2 == 0) mid = mid/2;
                else mid = (mid+1)/2;
                int b=0,total=0;
                while(total+cnt[b]<mid)///找到这个数所在的区间
                {
                    total+=cnt[b++];
                }
                i=b*block;///查询的数在这个区间的头和下一个区间的头之间
                while(total+bucket[i]<mid)///在该区间内查询中间值
                {
                    total+=bucket[i++];
                }

                printf("%d\n",i);///找到该中间值并输出
            }
        }
    }
    return 0;
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值