Parity game POJ - 1733(并查集加离散化)

Parity game POJ - 1733(并查集加离散化)

与POJ的食物链题同理
Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even' orodd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even' means an even number of ones andodd’ means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output
3
题意:给出区间长度和操作的次数,下面每一组是区间的左右端点和该区间的1个数的奇偶,这个区间只由0,1组成。问从第几句开始后面的话就都是假的,(也就是说前面的话都默认为真的)这个题与食物链的那道题类似,都是种类并查集。我们用r[i]存储该端点与根的关系,也就是该端点到根的区间里如果1的个数是奇数个就记为1,偶数个就记为0,也就是说将r[]控制在【0,1】之间,则每次r[i]更新完都要%2.另外值得注意的是该题数据量太多,需要对区间端点进行离散化,也就是说将用到的端点都顺序存下来,使用的时候只看这些点。
这里写图片描述

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<cmath>
using namespace std;
int n,m,t,cnt,ans;
char ch[10];
int fa[5000100],r[5000100];
void init()
{
    for(int i=0;i<5000100;i++)
    {
        fa[i]=i;
        r[i]=0;
    }
}
int find(int x)
{
    if(x==fa[x]) return x;
    int temp=fa[x];
    fa[x]=find(fa[x]);
    r[x]=(r[x]+r[temp])%2;//看图
    return fa[x];
}
int combine(int x,int y,int d)
{
    int t1=find(x);
    int t2=find(y);
    if(t1==t2)
    {
        if((r[x]+r[y])%2==d) return 1; //奇偶性相同,则正确
        else return 0;
    }
    else{
        fa[t1]=t2;
        r[t1]=(r[x]+r[y]+d)%2; //更新区间奇偶性
        return 1;
    }
}
int main()
{
    int i,a,b,x,y,d;
    scanf("%d%d",&n,&m);
    init();
    map<int,int>mm;
    cnt=ans=0;
    for(i=0;i<m;i++)
    {
        scanf("%d%d%s",&a,&b,ch);a--;
        if(mm.find(a)==mm.end())
            mm[a]=cnt++;
        if(mm.find(b)==mm.end())
            mm[b]=cnt++;
        x=mm[a],y=mm[b];     //使用map实现离散化
        if(ch[0]=='o') d=1;  //奇标记
        else d=0;            //偶标记
        if(combine(x,y,d)) ans++;
        else break;
    }
    printf("%d\n",ans);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值