jmu-Java-06异常-01-常见异常

自己编码以产生常见异常。

main方法:

  1. 事先定义好一个大小为5的数组。
  2. 根据屏幕输入产生相应异常

提示: 可以使用System.out.println(e)打印异常对象的信息,其中e为捕获到的异常对象。

输入说明:

  1. arr 代表产生访问数组是产生的异常。然后输入下标 ,如果抛出ArrayIndexOutOfBoundsException异常则显示,如果不抛出异常则不显示。
  2. null,产生NullPointerException
  3. cast,尝试将String对象强制转化为Integer对象,产生ClassCastException
  4. num,然后输入字符,转化为Integer,如果抛出NumberFormatException异常则显示。
  5. 其他,结束程序。

输入样例:

arr 4
null
cast
num 8
arr 7
num a
other

输出样例:

java.lang.NullPointerException
java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
java.lang.ArrayIndexOutOfBoundsException: 7
java.lang.NumberFormatException: For input string: "a"


答案

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        Integer[] arr = new Integer[5];
        label:
        while(scanner.hasNext()){
            String str = scanner.next();
            switch (str) {
                case "arr":
                    int index = scanner.nextInt();
                    try {
                        Integer test1 = arr[index];
                    } catch (ArrayIndexOutOfBoundsException e) {
                        System.out.println(e);
                    }
                    break;
                case "null":
                    try {
                        String test2 = null;
                        boolean b = test2.equals("null");
                    }catch (Exception e){
                        System.out.println(e);
                    }
                    break;
                case "cast":
                    try{
                        Object test3 = "1";
                        Integer s = (Integer)test3;
                    }catch (Exception e){
                        System.out.println(e);
                    }
                    break;
                case "num":
                    String temp = scanner.next();
                    try{
                        Integer temp1 = Integer.parseInt(temp);
                    }catch (NumberFormatException e){
                        System.out.println(e);
                    }
                    break;
                default:
                    break label;
            }
        }
    }
}
  • 8
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值