POJ2362 Square(dfs)

Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes


题意:

问给出的棍子可不可以凑成一个正方形


Note:

三处剪纸:  1.因为是正方形,棍子之和需整除4.  

  2.最短的木棒要比棍子平局数大。 

  3.dfs判断条件时只要三根棍子拼好即可。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int maxn = 30;
int n, side, stick[maxn];
bool vis[maxn];
bool cmp(int a, int b)
{
	return a > b;
}
bool dfs(int num, int len, int s)
{
	if(num == 3) return true;
	for(int i = s; i < n; ++i) {
		if(vis[i]) continue;
		vis[i] = true;
		if(len + stick[i] < side) {
			if(dfs(num, len + stick[i], i)) return true;
		}
		else if(len + stick[i] == side) {
			if(dfs(num + 1, 0, 0)) return true;
		}
		vis[i] = false;
	}
	return false;
}
int main(int argc, char const *argv[])
{
	int t;
	scanf("%d", &t);
	while(t--) {
		memset(stick, 0, sizeof(stick));
		memset(vis, false, sizeof(vis));
		int sum = 0;
		scanf("%d", &n);
		for(int i = 0; i < n; ++i) {
			scanf("%d", &stick[i]);
			sum += stick[i];
		}
		if(n < 4 || sum % 4 != 0) {
			printf("no\n");
			continue;
		}
		sort(stick, stick + n, cmp);
		side = sum / 4;
		if(side < stick[0]) {
			printf("no\n");
			continue;
		}
		if(dfs(0, 0, 0)) printf("yes\n");
		else printf("no\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值