POJ2502 Subway(Floyd)

Description

You have just moved from a quiet Waterloo neighbourhood to a big, noisy city. Instead of getting to ride your bike to school every day, you now get to walk and take the subway. Because you don't want to be late for class, you want to know how long it will take you to get to school. 
You walk at a speed of 10 km/h. The subway travels at 40 km/h. Assume that you are lucky, and whenever you arrive at a subway station, a train is there that you can board immediately. You may get on and off the subway any number of times, and you may switch between different subway lines if you wish. All subway lines go in both directions.

Input

Input consists of the x,y coordinates of your home and your school, followed by specifications of several subway lines. Each subway line consists of the non-negative integer x,y coordinates of each stop on the line, in order. You may assume the subway runs in a straight line between adjacent stops, and the coordinates represent an integral number of metres. Each line has at least two stops. The end of each subway line is followed by the dummy coordinate pair -1,-1. In total there are at most 200 subway stops in the city.

Output

Output is the number of minutes it will take you to get to school, rounded to the nearest minute, taking the fastest route.

Sample Input

0 0 10000 1000
0 200 5000 200 7000 200 -1 -1 
2000 600 5000 600 10000 600 -1 -1

Sample Output

21


输入确实是坑。。我在本地都没有办法测试数据 硬是wa了数十次


floyd dijkstra spfa均可做


我觉得这题比较难的是建图。。 其实是因为自己不会建。。。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "cmath"
using namespace std;
const int MAXN = 305;
struct node
{
	/* data */
	double x, y;
}point[MAXN];
double map[MAXN][MAXN], subv, walkv;
int n;
double dist(node a, node b)
{
	return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}
int main(int argc, char const *argv[])
{
	for(int i = 0; i < MAXN; ++i)
		for(int j = 0; j < MAXN; ++j)
			map[i][j] = -1;
	subv = 40 * 1000.0 / 60;
	walkv = 10 * 1000.0 / 60;
	for(int i = 0; i < 2; ++i)
		scanf("%lf%lf", &point[i].x, &point[i].y);
	n = 2;
	node last, now;
	last.x = last.y = -1;
	while(scanf("%lf%lf", &now.x, &now.y) != EOF) {
		if(!(now.x == -1 && now.y == -1)) {
			point[n++] = now;
			if(!(last.x == -1 && last.y == -1))
				map[n - 1][n - 2] = map[n - 2][n - 1] = dist(point[n - 1], point[n - 2]) / subv;
		}
		last = now;
	}
	for(int i = 0; i < n; ++i)
		for(int j = 0; j < n; ++j)
			if(map[i][j] == -1) map[i][j] = dist(point[i], point[j]) / walkv;
	for(int k = 0; k < n; ++k)
		for(int i = 0; i < n; ++i)
			for(int j = 0; j < n; ++j)
				map[i][j] = min(map[i][j], map[i][k] + map[k][j]);
	printf("%.0f\n", map[0][1]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值