HDOJ1175 连连看(bfs)

连连看

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25009    Accepted Submission(s): 6183


Problem Description
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
 

Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
 

Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
 

Sample Input
  
  
3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0
 

Sample Output
  
  
YES NO NO NO NO YES
 



模板题,多注意判断的细节就好。


AC代码:


<span style="font-size:14px;color:#33cc00;">#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "queue"
using namespace std;
const int MAXN = 1005;
const int INF = 0x3f3f3f3f;
int dir[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};
int map[MAXN][MAXN], vis[MAXN][MAXN], n, m, q;
struct node
{
	/* data */
	int x, y, dir, tim;
}st, ed;
void bfs()
{
	queue<node> q;
	node cur, pre;
	st.dir = -1, st.tim = 0;
	q.push(st);
	while(!q.empty()) {
		pre = q.front();
		q.pop();
		if(pre.x == ed.x && pre.y == ed.y) {
			printf("YES\n");
			return;
		}
		for(int i = 0; i < 4; ++i) {
			cur.x = pre.x + dir[i][0];
			cur.y = pre.y + dir[i][1];
			cur.tim = pre.tim;
			cur.dir = i;
			if(pre.dir != cur.dir && pre.dir != -1) cur.tim++;
			if(cur.x < 1 || cur.y < 1 || cur.x > n || cur.y > m || cur.tim > 2) continue;
			if(map[cur.x][cur.y] && !(cur.x == ed.x && cur.y == ed.y)) continue;
			if(cur.tim < vis[cur.x][cur.y]) {
				vis[cur.x][cur.y] = cur.tim;
				q.push(cur);
			}
		}
	}
	printf("NO\n");
}
int main(int argc, char const *argv[])
{
	while(scanf("%d%d", &n, &m) != EOF) {
		if(!m && !n) break;
		for(int i = 1; i <= n; ++i)
			for(int j = 1; j <= m; ++j)
				scanf("%d", &map[i][j]);
		scanf("%d", &q);
		while(q--) {
			scanf("%d%d%d%d", &st.x, &st.y, &ed.x, &ed.y);
			if(st.x == ed.x && st.y == ed.y) {
				printf("NO\n");
				continue;
			}
			if(!map[st.x][st.y] || !map[ed.x][ed.y] || map[st.x][st.y] != map[ed.x][ed.y]) {
				printf("NO\n");
				continue;
			}
			memset(vis, INF, sizeof(vis));
			bfs();
		}
	}
	return 0;
}</span>

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值