HDOJ1175 连连看(dfs)

连连看

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25057    Accepted Submission(s): 6195


Problem Description
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
 

Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
 

Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
 

Sample Input
  
  
3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0
 

Sample Output
  
  
YES NO NO NO NO YES
 



dfs写法和bfs写法一样,都是考查剪枝。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "queue"
using namespace std;
const int MAXN = 1005;
int dir[5][2] = {{0, 0}, {0, 1}, {1, 0}, {0, -1}, {-1, 0}};
int map[MAXN][MAXN], vis[MAXN][MAXN], n, m, q, stx, sty, edx, edy;
bool flag;
bool judge(int x, int y, int cdir)
{
	int dx = edx - x, dy = edy - y;
	if(dx) dx /= abs(dx);
	if(dy) dy /= abs(dy);
	if(dx == dir[cdir][0] && dy == dir[cdir][1]) return true;
	return false;
}
void dfs(int x, int y, int cnt, int cdir)
{
	if(flag) return;
	if(x < 1 || y < 1 || x > n || y > m || cnt > 2) return;
	if(x == edx && y == edy) {
		flag = true;
		return;
	}
	if(cnt == 2 && !judge(x, y, cdir)) return;
	if(map[x][y]) return;
	if(vis[x][y] != -1 && vis[x][y] <= cnt) return;
	vis[x][y] = cnt;
	for(int i = 1; i <= 4; ++i) {
		int dx = x + dir[i][0], dy = y + dir[i][1];
		if(cdir != i) dfs(dx, dy, cnt + 1, i);
		else dfs(dx, dy, cnt, i);
	}
}
int main(int argc, char const *argv[])
{
	while(scanf("%d%d", &n, &m) != EOF) {
		if(!m && !n) break;
		for(int i = 1; i <= n; ++i)
			for(int j = 1; j <= m; ++j)
				scanf("%d", &map[i][j]);
		scanf("%d", &q);
		while(q--) {
			scanf("%d%d%d%d", &stx, &sty, &edx, &edy);
			if(stx == edx && sty == edy) {
				printf("NO\n");
				continue;
			}
			if(!map[stx][sty] || !map[edx][edy] || map[stx][sty] != map[edx][edy]) {
				printf("NO\n");
				continue;
			}
			memset(vis, -1, sizeof(vis));
			flag = false;
			vis[stx][sty] = 0;
			for(int i = 1; i <= 4; ++i)
				dfs(stx + dir[i][0], sty + dir[i][1], 0, i);
			if(flag) printf("YES\n");
			else printf("NO\n");
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值