Color the ball
Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 13129 Accepted Submission(s): 6562
Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
当N = 0,输入结束。
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
Sample Output
1 1 1 3 2 1
树状数组模板题,简单的区间修改。
AC代码:
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 1e6 + 6;
int n, a[MAXN];
int lowbit(int x)
{
return x & (-x);
}
void update(int x, int v)
{
for(int i = x; i <= n; i += lowbit(i))
a[i] += v;
}
int get_sum(int x)
{
int sum = 0;
for(int i = x; i > 0; i -= lowbit(i))
sum += a[i];
return sum;
}
int main(int argc, char const *argv[])
{
while(scanf("%d", &n) != EOF && n) {
memset(a, 0, sizeof(a));
for(int i = 0; i < n; ++i) {
int a, b;
scanf("%d%d", &a, &b);
update(a, 1);
update(b + 1, -1);
}
for(int i = 1; i < n; ++i)
printf("%d ", get_sum(i));
printf("%d\n", get_sum(n));
}
return 0;
}