BestCoder Round #54 (div.2) HDOJ 5427 A problem of sorting(模拟)

34 篇文章 0 订阅
29 篇文章 0 订阅

A problem of sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 240    Accepted Submission(s): 115


Problem Description
There are many people's name and birth in a list.Your task is to print the name from young to old.(There is no pair of two has the same age.)


 

Input
First line contains a single integer  T100  which denotes the number of test cases. 

For each test case, there is an positive integer  n(1n100)  which denotes the number of people,and next  n  lines,each line has a name and a birth's year(1900-2015) separated by one space.

The length of name is positive and not larger than  100 .Notice name only contain letter(s),digit(s) and space(s).
 

Output
For each case, output  n  lines.
 

Sample Input
  
  
2 1 FancyCoder 1996 2 FancyCoder 1996 xyz111 1997
 

Sample Output
  
  
FancyCoder xyz111 FancyCoder
 



简单的模拟,注意名字中含有空格,gets()函数就搞定,还有pow()函数原型也要注意一下。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "cmath"
using namespace std;
const int MAXN = 105;
struct node
{
	/* data */
	char name[200];
	int age;
}a[MAXN];
bool cmp(node a, node b)
{
	return a.age > b.age;
}
int main(int argc, char const *argv[])
{
	int t;
	scanf("%d", &t);
	for(int cas = 0; cas < t; ++cas) {
		memset(a, 0, sizeof(a));
		int n;
		cin >> n;
		getchar();
		for(int i = 0; i < n; ++i) {
			gets(a[i].name);
			int len = strlen(a[i].name), num = 0;
			for(int j = len - 1; j >= len - 4; --j)
				a[i].age += ((int)(pow(10.0, num++))) * (a[i].name[j] - '0');
		}
		sort(a, a + n, cmp);
		for(int i = 0; i < n; ++i) {
			int len = strlen(a[i].name);
			a[i].name[len - 5] = '\0';
			printf("%s\n", a[i].name);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值