nyoj1103 卡特兰数

                   区域赛系列一多边形划分 

时间限制:1000 ms | 内存限制:65535 KB
难度:2
描述
Give you a convex(凸边形), diagonal n-3 disjoint divided into n-2 triangles(直线), for different number of methods, such as n=5, there are 5 kinds of partition method, as shown in Figure

输入
The first line of the input is a n (1<=n<=1000), expressed n data set.
The next n lines each behavior an integer m (3<=m<=18), namely the convex edges.
输出
For each give m,, output how many classification methods.
example output: Case #a : b
样例输入
3
3
4
5
样例输出
Case #1 : 1
Case #2 : 2
Case #3 : 5
提示
Catalan number

看完以后大概明白了题意,题意就是求凸n边形区域分成三角形区域的方法数。然后就开始想,刚开始没看到提示Catalan number,看完以后就百度了一下这是个什么东东,然后,,,感觉发现了新大陆,学习了。

*卡塔兰数是组合数学中一个常在各种计数问题中出现的数列。以比利时的数学家欧仁·查理·卡塔兰 (1814–1894)命名。
卡塔兰数的一般项公式为 C_n = \frac{1}{n+1}{2n \choose n} = \frac{(2n)!}{(n+1)!n!}
卡特兰数前几项为 :1, 1, 2, 5, 14, 42, 132, 429, 1430, 4862, 16796, 58786, 208012……*
递归式:令h(0)=1,h(1)=1,卡特兰数满足递归式:h(n)=h(0)*h(n-1)+h(1)*h(n-2)+…+h(n-1)*h(0); (n>=2)
另类递归式:h(n)=((4*n-2)/(n+1))*h(n-1);
只是把公式写了出来,想更深了解的话可以自己百度。。。

#include <iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
   int t,ans=1,n;
   double s,a[20];
   scanf("%d",&t);
   while(t--)
   {
       a[0]=1;
       a[1]=1;
       scanf("%d",&n);
       for(int i=1;i<=n-2;i++)
       {
           s=(4*i-2)/((i+1)*1.0);
           a[i]=s*a[i-1];
       }
       printf("Case #%d : %.0lf\n",ans++,a[n-2]);
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值