hdu5391

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1930 Accepted Submission(s): 977

Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become 2 times as large as the size on the first day. On the n-th day,it will become n times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.

Input
The first line of input contains an integer T, representing the number of cases.

The following T lines, each line contains an integer n, according to the description.
T≤105,2≤n≤109

Output
For each test case, output an integer representing the answer.

Sample Input
2
3
10

Sample Output
2
0

昨晚比赛的这道题,题意就是求n-1的阶乘对n取余的值,因为n的最大值为10的9次方,当时感觉用阶乘会超时,于是就开始看有没有规律可寻,找了前21个数,把他们的结果都列出来了,但硬是没看出来规律,太笨了,后来比赛结束后学长说了一下规律,我天哪,我的数据结果完全符合【流汗】但就是没有往那方面想,看来还是做题少。废话不说了,试着找一下前21个数的结果,你会发现这个规律的。。。(该猜题的时候就要大胆猜)。

#include<stdio.h>
#include<algorithm>
#include<stdlib.h>
#include<iostream>
#include<string.h>
#include<vector>
#include<queue>
#include<math.h>
using namespace std;
int _isprime(int m)
{
    for(int i=2; i<=sqrt(m); i++)
        if(m%i==0)
            return 0;
    return 1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        int sum;
        scanf("%d",&n);
        if(n==1)
            printf("0\n");
        else  if(_isprime(n))
            printf("%d\n",n-1);
        else
        {
            if(n==4)
                printf("2\n");
            else
                printf("0\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值