AtCoder Regular Contest 135 A

Problem Statement

There is an integer XX written on a blackboard. You can do the operation below any number of times (possibly zero).

  • Choose an integer xx written on the blackboard.
  • Erase one xx from the blackboard and write two new integers \lfloor \frac{x}{2}\rfloor⌊2x​⌋ and \lceil \frac{x}{2}\rceil⌈2x​⌉.

Find the maximum possible product of the integers on the blackboard after your operations, modulo 998244353998244353.

What are \lfloor \frac{x}{2}\rfloor⌊2x​⌋ and \lceil \frac{x}{2}\rceil⌈2x​⌉?

Constraints

  • 1\leq X \leq 10^{18}1≤X≤1018

Input

Input is given from Standard Input from the following format:

XX

Output

Print the maximum possible product of the integers on the blackboard after your operations, modulo 998244353998244353.


Sample Input 1 Copy

Copy

15

Sample Output 1 Copy

Copy

192

Here is a sequence of operations that makes the product of the integers on the blackboard 192192.

  • The initial state of the blackboard is (15)(15).
  • An operation with x = 15x=15 changes it to (7, 8)(7,8).
  • An operation with x = 7x=7 changes it to (8, 3, 4)(8,3,4).
  • An operation with x = 4x=4 changes it to (8, 3, 2, 2)(8,3,2,2).
  • An operation with x = 8x=8 changes it to (3, 2, 2, 4, 4)(3,2,2,4,4).

Here, the product of the integers on the blackboard is 3\times 2\times 2\times 4\times 4 = 1923×2×2×4×4=192.


Sample Input 2 Copy

Copy

3

Sample Output 2 Copy

Copy

3

Doing zero operations makes the product of the integers on the blackboard 33.


Sample Input 3 Copy

Copy

100

Sample Output 3 Copy

Copy

824552442

The maximum possible product of the integers on the blackboard after your operations is 58564588684700165856458868470016, which should be printed modulo 998244353998244353.

#include <bits/stdc++.h>
#define int long long
using namespace std;
int n,m=1,mod=998244353,sum;
map<int,int> p;
int f(int n)
{
    if(p[n]) return p[n];
    if(n<=3) return p[n]=n;
    return p[n]=f(n>>1)*f(n+1>>1)%mod;
}
signed main()
{
    cin>>n;
    cout<<f(n);
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GSYMG

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值