UVA1121 Subsequence 二分+前缀数组

Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 40   Accepted Submission(s) : 17
Problem Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
 

Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
 

Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
 

Sample Input
 
 
2 10 15 5 1 3 5 10 7 4 9 2 8 5 11 1 2 3 4 5
 

Sample Output
 
 
2 3
 

Source
PKU

题意:给n个数和一个数字s,输出最小连续子序列的和大于或等于s的的个数

思路:二分连续子序列的个数,用前缀数组求序列和

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<map>
using namespace std;
//const int MAXN = ;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int MAXN = 100010;
int a[MAXN];
ll sum[MAXN];
int n;
ll s;
int solve(int len){
    for(int i=0;i+len<n;i++){
        if(sum[i+len]-sum[i]+a[i]>=s){
            return 1;
        }
    }
    return 0;
}
int main(void){
    int t;
    scanf("%d",&t);
        while(t--){
           scanf("%d%d",&n,&s);
           scanf("%d",&a[0]);
           sum[0]=a[0];
           for(int i=1;i<n;i++){
               scanf("%d",&a[i]);
               sum[i]=sum[i-1]+a[i];
           }
           if(sum[n-1]<s){
              printf("0\n");
              continue;
           }
           int flag=0;
           int ans=INF;
           int l=0,r=n-1;
           int mid;
           while(l<=r){
                 mid=(l+r)/2;
                 if(solve(mid)){
                      ans=min(ans,mid);
                      flag=1;
                      r=mid-1;
                 }else l=mid+1;
           }
           if(flag){
              printf("%d\n",ans+1);
           }else{
              printf("0\n");
           }
       }    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值