HDU 5093 Battle ships (二分图匹配)

Battle ships

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1857    Accepted Submission(s): 686


 

Problem Description

Dear contestant, now you are an excellent navy commander, who is responsible of a tough mission currently.

Your fleet unfortunately encountered an enemy fleet near the South Pole where the geographical conditions are negative for both sides. The floating ice and iceberg blocks battleships move which leads to this unexpected engagement highly dangerous, unpredictable and incontrollable. 

But, fortunately, as an experienced navy commander, you are able to take opportunity to embattle the ships to maximize the utility of cannons on the battleships before the engagement. 

The target is, arrange as many battleships as you can in the map. However, there are three rules so that you cannot do that arbitrary:

A battleship cannot lay on floating ice
A battleship cannot be placed on an iceberg

Two battleships cannot be arranged in the same row or column, unless one or more icebergs are in the middle of them.

 

 

Input

There is only one integer T (0<T<12) at the beginning line, which means following T test cases.

For each test case, two integers m and n (1 <= m, n <= 50) are at the first line, represents the number of rows and columns of the battlefield map respectively. Following m lines contains n characters iteratively, each character belongs to one of ‘#’, ‘*’, ‘o’, that symbolize iceberg, ordinary sea and floating ice.

 

 

Output

For each case, output just one line, contains a single integer which represents the maximal possible number of battleships can be arranged.

 

 

Sample Input

 

2 4 4 *ooo o### **#* ooo* 4 4 #*** *#** **#* ooo#

 

 

Sample Output

 

3 5

 

 

Source

2014上海全国邀请赛——题目重现(感谢上海大学提供题目)

题意:给出一个n行m列的图,*代表海域,o代表冰水,#代表冰山,要想在海域中放置船,保证船与船之间不能相互看到,之间只要有山就不能看到,问最多能放多少船。

思路:一看到这道题就想到了二分图,之前做二分图专题的时候有很多以横坐标为X集合,纵坐标为Y集合然后进行二分匹配的题,这道题不一样的地方就是有了冰山,限时训练的时候被这点难住了,看了题解发现道理是一样的,只是这里的行和列并不是严格意义上的行和列了,而是变成了行块和列块,将一片最多只能放一个船的连续网格叫做‘块’,然后分别给行块和列块进行标号,所有行块为X集合,所有列块为Y集合,X集合的点与Y集合的点有边相连当且仅当这两个点共用一个海洋格子。然后跑二分最大匹配,如何给块标号也值得学习一下。

#include <stdio.h>
#include <string.h>

char str[55][55];
int match[55 * 55],used[55 * 55];
int x[55][55],y[55][55];
int mp[55 * 55][55 * 55];
int cntx,cnty;

bool dfs(int u)
{
    for(int i = 1; i <= cnty; i++) {
        if(mp[u][i] && !used[i]) {
            used[i] = 1;
            if(match[i] == -1 || dfs(match[i])) {
                match[i] = u;
                return true;
            }
        }
    }
    return false;
}
int max_match()
{
    int ans = 0;
    memset(match,-1,sizeof(match));
    for(int i = 1; i <= cntx; i++) {
        memset(used,0,sizeof(used));
        if(dfs(i)){
            ans++;
        }
    }
    return ans;
}

int main(void)
{
    int T;
    scanf("%d",&T);
    while(T--) {
        int n,m;
        scanf("%d%d",&n,&m);
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));
        memset(mp,0,sizeof(mp));
        for(int i = 0; i < n; i++) {
            scanf("%s",str[i]);
        }

        //给行块标号
        cntx = 1;
        for(int i = 0; i < n; i++) {
            for(int j = 0; j < m; j++) {
                if(str[i][j] == '*') {
                    x[i][j] = cntx;
                }
                if(str[i][j] == '#') {
                    cntx++;
                }
            }
            cntx++;
        }
        //给列块标号
        cnty = 1;
        for(int i = 0; i < m; i++) {
            for(int j = 0; j < n; j++) {
                if(str[j][i] == '*') {
                    y[j][i] = cnty;
                }
                if(str[j][i] == '#') {
                    cnty++;
                }
            }
            cnty++;
        }
        //建图
        for(int i = 0; i < n; i++) {
            for(int j = 0; j < m; j++) {
                if(str[i][j] == '*') {
                    mp[x[i][j]][y[i][j]] = 1;
                }
            }
        }

        printf("%d\n",max_match());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值