《ACM程序设计》书中题目 Y - 25 数字表述

Description

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.

Input

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.

Output

For each test case, print the string that follows the given string.

Sample Input



3
122344111
1111111111
12345

Sample Output



1122132431
101
1112131415

    

    这道题的基本题意为给出一串数字,用几个几这样的形式表述,只显示数字。例:122344111为1个1、2个2、1个3、2个4、3个1,所以表述为1122132431。


源代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
int n,i,j,k;
string a;
char b;
cin>>n;
for(i=0;i<n;++i)
{ cin>>a;
 for(j=0,b=a[0],k=0;j<a.size();++j)
  { if(a[j]==b)++k;
    if(a[j]!=b||j==a.size()-1) 

        cout<<k<<b;
        b=a[j];
        k=1;
}
   if(j==a.size()-1&&a[j]!=a[j-1]&&a.size()>1)
   cout<<1<<a[j];
       }
       cout<<endl;
    }


     这道题需要特别注意临界条件,如当只有一个数时,还有当判断到最后一位时。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值