Gold Rush



Description

Input

Output

Sample Input

3
2 2 2
2 1 3
10 1000 24

Sample Output

1
2
7

HINT

Source

贪心算法,注意变量在作用域中值的变化

#include<iostream>
#include<math.h>
using namespace std;

main()
{
 int t,n;
 scanf("%d",&t);
 long long  a,b,tmp;
 while(t--)
 {
  scanf("%d%lld%lld",&n,&a,&b);
  long long sum=1,qun=0;
  for(int i=0;i<n;i++)
    sum=2*sum;
        a=max(a,b);
       // printf("%lld %lld\n",a,sum);
        if(a==sum)
        {
         printf("0\n");
         continue;
        }
  while(a>0)
        {
         tmp=sum/2;
         sum=tmp;
         if(a>=tmp)
           a=a-tmp;
           qun++;
        }
        printf("%lld\n",qun);
 }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值