计蒜客Gold-Rush水题

题意:

Alice and Bob are on an adventure trip. Deep in the woods they discover a mysterious deep cave which they enter flutteringly. They find an old console with a giant bar of gold in it. On the bar, there is a number n. Both tried to carry the gold out the cave, but it was still to heavy for one of them.

Suddenly a little fairy appears in the corner of the cave and approaches Alice and Bob: “This gold is heavy. It weights 2^n femto-grams (10^−15) and nncan reach 62.”

Bob answered: “What luck! Alice’s knapsack can carry up to aa femto-grams and mine bb femto-grams with a+b=2^n.” Alice interjected: “But how can we divide the gold?”

Fairy: “I can help you with a spell that can burst one piece of gold into two equally weighted ones. But for each single spell, the cave will be locked one additional day.”

Alice consults with Bob to use the help of the fairy and take all of the gold. How long will they be trapped if they are clever?

Input

The input starts with the number t≤1000 of test cases.

Then tt lines follow, each describing a single test case consisting of three numbers n,an,a and bb with a,b≥1,a+b=2^n, and 1≤n≤62.

Output

Output one line for every test case with the minimal number of days that Alice and Bob are locked in the cave.

样例输入
3
2 2 2
2 1 3
10 1000 24
样例输出
1
2
7

​ 翻译成汉语大概意思就是有T组样例,每组样例有一个数是2^n,把它分成a,b,每次只能把一个数分成两个该数的一半,问最少分多少次能够分成a,b巴拉巴拉~

思路:

​ 我们只需要得到a,b的最小值t,然后循环把2^n累除2,若比t小就用t-该数,直到t为0为止

代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
long long n;
long long quick(long long a, long long b) {
    long long ans = 1;
    while(b) {
        if(b&1) ans *= a;
        a *= a;
        b >>= 1;
    }
    return ans;
}
int main() {
    int T;
    long long n, a, b;
    scanf("%d", &T);
    while(T--) {
        scanf("%lld%lld%lld", &n, &a, &b);
        long long res = quick(2, n);
        long long minn = min(a, b);
        int num = 0;
        while(minn) {
            res /= 2;
            num++;
            if(res <= minn) {
                minn -= res;
            }
        }
        printf("%d\n", num);
    }
    return 0;
}

转载请注明出处!!!

如果有写的不对或者不全面的地方 可通过主页的联系方式进行指正,谢谢

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值