hdu 1506 最大子矩形

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
  
  
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
  
  
8 4000

题意概括:有n个矩形按输入顺序连接在一起,现在需要找到在这些连续的矩形组成的不规则图形里面找到一个面积最大的矩形。

解题思路:从每个矩形的右边和左边分别开始找比它高的矩形,遇到比它低的停止,看最多有几矩形标记位置,然后遍历每个矩形找出以该矩形为中心向两边扩散(扩散到之前标记的位置)构成的最大矩形。

代码:

#include<stdio.h>
long long n,a[100100],i,k,l[100100],r[100100],t;
int main()
{	
	while(scanf("%lld",&n),n)
	{
		for(i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
		}
		l[1]=1;
		r[n]=n;
		
		for(i=2;i<=n;i++)  //找到每个矩形的右边最多有几个比该矩形高,遇到比它低的截止 
		{				   //因为如果选用了比它低的它自身就失去了意义 
			t=i;
			while(t>1&&a[i]<=a[t-1])
			{
				t=l[t-1];
			} 
			l[i]=t;
		}
		for(i=n-1;i>=1;i--)//找到每个矩形的左边最多有几个比该矩形高,遇到比它低的截止 
		{				   //因为如果选用了比它低的它自身就失去了意义 
			t=i;
			while(t<n&&a[i]<=a[t+1])
			{
				t=r[t+1];
			} 
			r[i]=t;
		}
		long long  max=-1;
	
		for(i=1;i<=n;i++)  //遍历所以矩形,找出以这个矩形为中心向两边扩散的最大面积 
		{
			if(max<(r[i]-l[i]+1)*a[i])
			{
				max=(r[i]-l[i]+1)*a[i];
			}
		}
		printf("%lld\n",max);
		
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值