HDU-1506最大矩形问题(一)


做到很多关于最大矩形系列的题目,后来觉得还是写到微博上吧,以后找起来也好找,


HDU-1506 :这是这一系列的基础题

E - Largest Rectangle in a Histogram
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

思路:

算是动态规划的思路吧,要多设两个数组r[n],l[n],先控制输入各个小矩形的高a[i],每个a[i]都对应一个r[i],l[i],分别表示以a[i]为最低高的的最大矩形的最右边的位置跟最左边的位置,同时a[i]对应的最大矩形的面积为S=(r[i]-l[i]+1)*a[i],然后找到最大的S即可;具体的计算r[i]跟l[i]的算法就不慢慢讲了,直接看代码吧:

<span style="font-family:KaiTi_GB2312;font-size:24px;">//Li Wenjun
//emai:1542113545@qq.com
/*
「“04.24,サクラと东京スカイツリーに行った。そこは世界で一番暖かいところだ。”
“04.26,サクラと明治神宫に行った。そこで结婚式お挙げる人がいた。”
“04.25,サクラとデイズニーに行った。お化け屋敷が怖かったけど、サクラがいたから、全然怖くわなかった。”
“サクラのことが大好き。”」
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include <iostream>
#include <algorithm>
using namespace std;
__int64 l[100005],r[100005],a[100005];
int main()
{
    freopen("in.txt","r",stdin);
    __int64 n,maxs,temp;
    while( cin>>n,n)
    {
        memset(a,0,sizeof(a));
        memset(r,0,sizeof(r));
        memset(l,0,sizeof(l));
        a[0]=-1;a[n+1]=-1;
        for(__int64 i=1;i<=n;i++)
        {
            cin>>a[i];
            l[i]=r[i]=i;
            while(a[l[i]-1]>=a[i])
                l[i]=l[l[i]-1];
        }
        for(__int64 i=n-1;i>=1;i--)
        {
            while(a[r[i]+1]>=a[i])
                r[i]=r[r[i]+1];
        }
        maxs=0;
        for(__int64 i=1;i<=n;i++)
        {
            temp=a[i]*(r[i]-l[i]+1);
            if(temp>maxs)
                maxs=temp;
        }
        cout<<maxs<<endl;
    }
    return 0;
}
</span>











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值