HDU ACM 1008 Elevator

Problem Description
The highest building in our city has only one elevator. A requestlist is made up with N positive numbers. The numbers denote atwhich floors the elevator will stop, in specified order. It costs 6seconds to move the elevator up one floor, and 4 seconds to movedown one floor. The elevator will stay for 5 seconds at eachstop.

For a given request list, you are to compute the total time spentto fulfill the requests on the list. The elevator is on the 0thfloor at the beginning and does not have to return to the groundfloor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positiveinteger N, followed by N positive numbers. All the numbers in theinput are less than 100. A test case with N = 0 denotes the end ofinput. This test case is not to be processed.
 

Output
Print the total time on a single line for each testcase. 
 

Sample Input
 
  
1 2 32 3 1 0
 

Sample Output
 
  
1741
 
Java Code:
import java.util.Scanner;
public class P1008 {
	public static void main(String[] args) {
		Scanner s = new Scanner(System.in);
		while (s.hasNext()) {
			int n = s.nextInt();
			if (n == 0) {
				return;
			}
			int time = 0;
			int[] arr = new int[n];
			for (int i = 0; i < n; i++) {
				arr[i] = s.nextInt();
			}
			if (n != 1) {
				time += arr[0] * 6 + 5;// 17
				for (int i = 0; i < n - 2; i++) {
					if (arr[i + 1] > arr[i]) {
						time += (arr[i + 1] - arr[i]) * 6 + 5;// 28
					} else {
						time += (arr[i] - arr[i + 1]) * 4 + 5;
					}
				}
				if (arr[n - 1] < arr[n - 2]) {
					time += (arr[n - 2] - arr[n - 1]) * 4 + 5;
				} else {
					time += (arr[n - 1] - arr[n - 2]) * 6 + 5;
				}
			} else {
				time = arr[0] * 6 + 5;
			}
			System.out.println(time);
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值