Problem A: 平面上的点和线——Point类、Line类 (VI)

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。
接口描述:
Point::show()方法:按格式输出Point对象。
Point::x()方法:取x坐标。
Point::y()方法:取y坐标。
Line::show()方法:按格式输出Line对象。
Line::SetLine(double, double, double, double)方法:设置Line对象起点的x,y坐标(第一个和第二参数)和终点的x,y坐标(第三个和第四个坐标),并返回本对象
Line::SetLine(const Point &, const Point &)方法:设置Line对象的起点(第一个参数)和终点(第二个坐标),并返回本对象
Line::SetLine(const Line&)方法:设置Line对象,复制参数的坐标,并返回本对象
Line::readLine()方法:从标准输入上读入坐标,格式见Sample
Line::start()方法:取Line的起点
Line::end()方法:取Line的终点
Line::setStart()方法:设置Line的起点
Line::setEnd()方法:设置Line的终点
以下三个函数用于输出Line对象,格式同sample
showLineCoordinate(const Line&)
showLinePoint(const Line&)
showLine(const Line&)

Input

输入的第一行为N,表示后面有N行测试样例。
每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。
C语言的输入输出被禁用。

Sample Input

40,0 1,11,1 2,32,3 4,50,1 1,0

Sample Output

Point : (1, -2) is created.Point : (2, -1) is created.Point : (0, 0) is created.Point : (0, 0)Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Line : (0, 0) to (1, 1)Line : (1, 1) to (2, 3)Line : (2, 3) to (4, 5)Line : (0, 1) to (1, 0)Point : (1, -2) is copied.Point : (2, -1) is copied.Line : (1, -2) to (2, -1) is created.Point : (1, -2) is copied.Point : (0, 0) is copied.Line : (1, -2) to (0, 0) is created.Point : (2, -1) is copied.Point : (0, 0) is copied.Line : (2, -1) to (0, 0) is created.Point : (1, -2) is copied.Point : (2, -1) is copied.Line : (1, -2) to (2, -1) is copied.Line : (1, -2) to (2, -1)Line : Point : (1, -2) to Point : (0, 0)Line : Point : (1, -2) to Point : (2, -1)Line : (0, 0) to (2, -1)Line : (0, 0) to (2, -1) is erased.Point : (2, -1) is erased.Point : (0, 0) is erased.Line : (1, -2) to (2, -1) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.Line : (1, -2) to (0, 0) is erased.Point : (0, 0) is erased.Point : (1, -2) is erased.Line : (1, -2) to (2, -1) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.Line : (0, 1) to (1, 0) is erased.Point : (1, 0) is erased.Point : (0, 1) is erased.Line : (2, 3) to (4, 5) is erased.Point : (4, 5) is erased.Point : (2, 3) is erased.Line : (1, 1) to (2, 3) is erased.Point : (2, 3) is erased.Point : (1, 1) is erased.Line : (0, 0) to (1, 1) is erased.Point : (1, 1) is erased.Point : (0, 0) is erased.Line : (0, 0) to (2, -1) is erased.Point : (2, -1) is erased.Point : (0, 0) is erased.Point : (0, 0) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.

HINT

Append Code

append.cc


平面的点应该到这就结束了(猜测),

因为七和六不是一个板子了(差的比较大).

撑住啊,童鞋们.

#include<iostream>
using namespace std;
class Point
{
public:
    double x0,y0;
    Point(double a,double b):x0(a),y0(b)
    {
        cout<<"Point : ("<<a<<", "<<b<<") is created."<<endl;
    }
    void cinn(double a,double b)
    {
        x0=a;
        y0=b;
    }
    Point():x0(0),y0(0)
    {
        cout<<"Point : (0, 0) is created."<<endl;
    }
    Point(const Point  & p1 )
    {
        x0=p1.x0;
        y0=p1.y0;
        cout<<"Point : ("<<x0<<", "<<y0<<") is copied."<<endl;
    }
    void show()
    {
        cout<<"Point : ("<<x0<<", "<<y0<<")"<<endl;
    }
    ~Point()
    {
        cout<<"Point : ("<<x0<<", "<<y0<<") is erased."<<endl;
    }
    void showNoEndOfLine() const
    {
        cout<<"Point : ("<<x0<<", "<<y0<<")";
    }
    double x()const
    {
        return x0;
    }
    double y()const
    {
        return y0;
    }
};
class Line
{
private:
    Point c,d;
    //double x1,y1,x2,y2;
public:
    Line& setStart(Point& t)
    {
        c=t;
        return *this;
    }
    Line& setEnd(Point& t)
    {
        d=t;
        return *this;
    }
    Line& setLine(Point& a,Point& b)
    {
        c=a;
        d=b;
        return *this;
    }
    Line& setLine(Line& a)
    {
        c=a.c;
        d=a.d;
        return *this;
    }
    Line(const Line & ll):c(ll.c),d(ll.d)
    {
        cout<<"Line : ("<<c.x0<<", "<<c.y0<<") to ("<<d.x0<<", "<<d.y0<<") is copied."<<endl;
    }
    Line & readLine()
    {
        double i,j,q,k;
        char c1;
        cin>>i>>c1>>j>>q>>c1>>k;
        c.cinn(i,j);
        d.cinn(q,k);
        return *this;
    }
    Line & SetLine(const Line & p)
    {
        c=p.c;
        d=p.d;
        return *this;
    }
    Line & SetLine(const Point & p,const Point & q)
    {
        c=p;
        d=q;
        return *this;
    }
    Line & SetLine(double a1, double b1, double c1, double d1)
    {
        c.x0=a1;
        c.y0=b1;
        d.x0=c1;
        d.y0=d1;
        return *this;
    }
    Line():c(0,0),d(0,0)
    {
        cout<<"Line : (0, 0) to (0, 0) is created."<<endl;
    }
    Line(double a,double b,double c,double d):c(a,b),d(c,d)
    {
        cout<<"Line : ("<<a<<", "<<b<<") to ("<<c<<", "<<d<<") is created."<<endl;
    }
    Line(const Point &a,const Point & b):c(a),d(b)
    {
        cout<<"Line : ("<<a.x0<<", "<<a.y0<<") to ("<<b.x0<<", "<<b.y0<<") is created."<<endl;
    }
    ~Line()
    {
        cout<<"Line : ("<<c.x0<<", "<<c.y0<<") to ("<<d.x0<<", "<<d.y0<<") is erased."<<endl;
    }
    void show()const
    {
        cout<<"Line : ("<<c.x0<<", "<<c.y0<<") to ("<<d.x0<<", "<<d.y0<<")"<<endl;
    }
    const Point& start() const
    {
        return c;
    }
    const Point& end() const
    {
        return d;
    }
};
void showLineCoordinate(const Line& line)
{
    std::cout<<"Line : ";
    std::cout<<"("<<line.start().x()<<", "<<line.start().y()<<")";
    std::cout<<" to ";
    std::cout<<"("<<line.end().x()<<", "<<line.end().y()<<")";
    std::cout<<std::endl;
}
 
void showLinePoint(const Line& line)
{
    std::cout<<"Line : ";
    line.start().showNoEndOfLine();
    std::cout<<" to ";
    line.end().showNoEndOfLine();
    std::cout<<std::endl;
}
 
void showLine(const Line& line)
{
    line.show();
}
 
int main()
{
    int num, i;
    Point p(1, -2), q(2, -1), t;
    t.show();
    std::cin>>num;
    Line line[num + 1];
    for(i = 1; i <= num; i++)
    {
        line[i].readLine();
        showLine(line[i]);
    }
    Line l1(p, q), l2(p,t), l3(q,t), l4(l1);
    showLineCoordinate(l1);
    showLinePoint(l2);
    showLinePoint(l3.setLine(l1));
    showLineCoordinate(l4.setLine(t,q));
    line[0].setStart(t);
    line[0].setEnd(q);
}
 
/**************************************************************
    Problem: 1332
    User: 201701060928
    Language: C++
    Result: Accepted
    Time:28 ms
    Memory:1272 kb
****************************************************************/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值