POJ_3519 Median

Median

题目链接

POJ_3519 Median

Description

Given N N N numbers, X 1 , X 2 , . . . , X N X1, X2, ... , XN X1,X2,...,XN, let us calculate the difference of every pair of numbers: ∣ X i − X j ∣ ( 1 ≤ i < j ≤ N ) |Xi - Xj| (1 ≤ i < j ≤ N) XiXj(1ijN). We can get C ( N , 2 ) C(N,2) C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the ( m / 2 ) − t h (m/2)-th (m/2)th smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N N N will be given in the first line. Then N numbers are given, representing X 1 , X 2 , . . . , X N , ( X i ≤ 1 , 000 , 000 , 0003 ≤ N ≤ 1 , 00 , 000 ) X_1, X_2, ... , X_N, ( X_i ≤ 1,000,000,000 3 ≤ N ≤ 1,00,000 ) X1,X2,...,XN,(Xi1,000,000,0003N1,00,000)

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

解析

本题中,数列中数的顺序对结果不会有影响

我们是使用二分答案来求中位数的值。先对数列进行排序。接着,分别枚举 ∣ X i − X j ∣ ( 1 ≤ i < j ≤ N ) |Xi - Xj| (1 ≤ i < j ≤ N) XiXj(1ijN) 中的 i i i j j j,求出有多少个 ∣ X i − X j ∣ |Xi - Xj| XiXj 的值大于等于(或小于)二分值,再根据这个结果继续二分。

代码

#include<algorithm>
#include<cstdio>
#include<queue>
#include<iostream>
#include<cmath>
using namespace std;
long long n,a[100001],l,r,mid,cnt,maxx,ans;
int main()
{
	while(scanf("%lld",&n)!=EOF)
	{
		maxx=n*(n-1)/2;
		for(int i=1;i<=n;i++)
			scanf("%lld",&a[i]);
		sort(a+1,a+n+1);
		l=0,r=2147483647;
		while(l<=r)//二分答案求中位数 
		{
			cnt=0;
			mid=(l+r)/2;
			int j=1;//左端点 
			for(int i=2;i<=n;i++)//右端点 
			{
				while(a[i]-a[j]>=mid)
					j++;
				cnt+=i-j;
			}
			if(cnt<maxx/2+maxx%2)//中位数太小 
			{
				ans=mid;
				l=mid+1;
			} 
			else//中位数太大 
				r=mid-1;
		}
		printf("%lld\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值