title: 平衡二叉树(AVL)
date: 2020-01-14 11:26:36
tags: 数据结构
1.1平衡二叉树的定义
为了解决二叉查找树如果插入的顺序不合适,会导致二叉查找树变成一个单链(可以看二叉查找树文章当中的讨论),例如按照递增序列建立二叉查找树就会导致一边倒的情况,从而无法发挥二叉树可以使得查找保持O(logn)查找的效率。故由使得二叉树的层数越小,导出了平衡二叉树。
AVL依然是一棵二叉查找树(AVL的命名是由发现这个树的两个苏联科学家G.M.Adekse-Velskil和E.M.Landis提出的),因此一般也称作AVL树。
左子树和右子树的高度之差称为该结点的平衡因子
由于需要对每个结点都要得到平衡因子,故在树的结点中加入一个height用以记录当前结点为根结点的子树的高度
struct node {
int v, height; //v为结点权值 height为当前子树高度
node *lchild, *rchild; //左右孩子结点地址
};
新建结点写法:
node* newNode(int v) {
node* Node = new node;
Node->v = v; //结点权值
Node->height = 1; //结点高度初始为1
Node->lchild = Node->rchild = NULL; //初始状态无左右孩子
return Node;
}
获取子树当前结点root所在的子树当前高度:
//获取以root为根结点的子树当前的height
int getHeight(node* root) {
if(root == NULL) return 0; //空结点高度为0
return root->height;
}
平衡因子的计算:
//平衡因子
int getBalanceFactor(node* root) {
//左子树高度减右子树高度
return getHeight(root->lchild) - getHeight(root->rchild);
}
思考:为什么不直接记录结点的平衡因子而是记录高度?因为没有办法直接获得当前子树的平衡因子计算得到该结点的平衡因子,而需要借助子树的高度间接求得。显然,结点root所在子树height等于 其左子树的height与其右子树的height的较大值+1,因此可以通过如下的函数更新height:
void updateHeight(node* root) {
//max(左孩子hight, 右孩子height) + 1
root->height = max(getHeight(root->lchild), getHeight(root->rchild)) + 1;
}
2 平衡二叉树的基本操作
AVL基本操作有查找、插入、建树以及删除。删除操作比较复杂,主要介绍AVL查找、插入和建立
2.1查找操作
//查找操作
void search(node* root, int x) {
if(root == NULL) { //空树 查找失败
printf("search faild\n");
return;
}
if(x == root->data) { //查找成功访问
printf("%d\n", root->data);
} else if(x < root->data) {
search(root->lchild, x);
} else {
search(root->rchild, x);
}
}
2.2插入操作
先介绍两种基本操作,是插入操作判定是哪种模式后要做的旋转基本操作。
//左旋(left Rotation
void L(node* &root) {
node* temp = root->rchild;
root->rchild = temp->lchild;
temp->lchild = root;
updataHeight(root);
updataHeight(temp);
root = temp;
}
同样还有一个右旋
//右旋(Right Rotation)
void R(node* &root) {
node* temp = root->lchild;
root->lchild = temp->rchild;
temp->rchild = root;
updateHeight(root);
updateHeight(temp);
root = temp;
}
可见左旋和右旋为一对相反的过程。
假定有一个平衡二叉树,插入一个结点后有可能会有结点的平衡因子的绝对值大于1,只要把最靠近插入结点的失衡结点调整到正常,路径上的所有结点就会平衡
注意平衡因子我们是左子树与右子树的高度之差,求root点平衡因子的函数所写为BF(root)
因此有如下的表格:
树形 | 调整方法 | |
---|---|---|
LL | BF(root) = 2, BF(root->lchild) = 1 | 对root进行右旋 |
LR | BF(root) = 2, BF(root->lchild) = -1 | 先对root->lchild进行左旋,再对root进行右旋 |
RR | BF(root) = -2, BF(root->rchild) = -1 | 对root进行左旋 |
RL | BF(root) = -2, BF(root->rchild) = 1 | 先对root->rchild进行右旋,再对root进行左旋 |
插入代码的实现,AVL树的插入代码是在二叉查找树的插入代码的基础上加入平衡操作,不考虑平衡操作,代码如下:
//插入权值为v的结点
void insert(node* &root, int v) {
if(root == NULL) { //到达空结点
root = newNode(v);
return;
}
if(v < roor->v) { //v比根结点的权值小
insert(root->lchild, v);
} else {
insert(root->rchild, v);
}
}
在此基础上 需要从插入结点从下向上判断结点的平衡,故在每次insert函数之后更新子树的高度,并且根据树形是LL型、LR型、RR型、RL型之一来进行平衡操作
//插入权值为v的结点
void insert(node* &root, int v) {
if(root == NULL) { //到达空结点
root = newNode(v);
return;
}
if(v < root->v) { //v比根结点的权值小
insert(root->lchild, v); //往左子树插入
updateHeight(root); //更新树高
if(getBalanceFactor(root) == 2) { //根结点出现不平衡
if(getBalanceFactor(root->lchild) == 1) { //LL型
R(root);
} else if(getBalanceFactor(root->lchild) == -1) { //LR型
L(root->lchild);
R(root);
}
}
} else { //v比根结点的权值大
insert(root->rchild, v); //往右子树插入
updateHeight(root); //更新树高
if(getBalanceFactor(root) == -2) {
if(getBalanceFactor(root->rchild) == -1) { //RR型
L(root);
} else if(getBalanceFactor(root->rchild) == 1) { //RL型
R(root->rchild);
L(root);
}
}
}
}
3 AVL树的建立
有了上面的基础我们AVL树的建立就是一步一步插入结点。边插入边调整树平衡。
//AVL树的建立
node* Create(int data[], int n) {
node* root = NULL; //新建空根结点
for(int i = 0; i < n; i++) {
insert(root, data[i]); //将data[0]~data[n-1]插入AVL树中
}
return root; //返回根结点
}
4 例题:
An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property.
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the root of the resulting AVL tree in one line.
Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88
代码
#include<cstdio>
#include<algorithm>
using namespace std;
struct node {
int v, height; //v为结点权值, height为当前子树高度
node *lchild, *rchild; //左右孩子结点地址
} *root;
//生成一个新结点,v为结点权值
node* newNode(int v) {
node* Node = new node; //申请一个node型变量的地址空间
Node->v = v; //结点权值为v
Node->height = 1; //结点初始高度为1
Node->lchild = Node->rchild = NULL; //初始状态下没有左右孩子结点
return Node;
}
int getHeight(node* root) {
if(root == NULL) return 0; //空结点高度为0
return root->height;
}
void updateHeight(node* root) {
//max(左孩子结点的height, 右孩子结点的height)+1
root->height = max(getHeight(root->lchild), getHeight(root->rchild)) + 1;
}
int getBalanceFactor(node* root) {
//左子树高度减去右子树高度
return getHeight(root->lchild) - getHeight(root->rchild);
}
//左旋 (Left Rotation)
void L(node* &root) {
node* temp = root->rchild;
root->rchild = temp->lchild;
temp->lchild = root;
updateHeight(root); //更新结合A的高度
updateHeight(temp); //更新结点B的高度
root = temp;
}
//右旋(Right Rotation)
void R(node* &root) {
node* temp = root->lchild;
root->lchild = temp->rchild;
temp->rchild = root;
updateHeight(root);
updateHeight(temp);
root = temp;
}
//插入权值为v的结点
void insert(node* &root, int v) {
if(root == NULL) { //到达空结点
root = newNode(v);
return;
}
if(v < root->v) { //v比根结点权值小
insert(root->lchild, v); //往左子树插入
updateHeight(root); //更新树高
if(getBalanceFactor(root) == 2) {
if(getBalanceFactor(root->lchild) == 1) { //LL型
R(root);
} else if(getBalanceFactor(root->lchild) == -1) { //LR型
L(root->lchild);
R(root);
}
}
} else { //v比根结点权值大
insert(root->rchild, v); //往右子树插入
updateHeight(root); //更新树高
if(getBalanceFactor(root) == -2) {
if(getBalanceFactor(root->rchild) == -1) { //RR型
L(root);
} else if(getBalanceFactor(root->rchild) == 1) { //RL型
R(root->rchild);
L(root);
}
}
}
}
//node* Create(int data[], int n) {
// node* root = NULL; //新建空根结点root
// for(int i = 0; i < n; i++) {
// insert(root, data[i]); //将data[0]~data[n-1]插入AVL
// }
// return root;
//}
int main() {
int n, v;
scanf("%d", &n);
for(int i = 0; i < n; i++) {
scanf("%d", &v);
insert(root, v);
}
printf("%d\n", root->v);
return 0;
}