三个正整数排序

输入三个正整数排序,样例输入20 7 33;样例输出:7 20 33

代码一:一般排序法

import java.util.Scanner;

public class PaiXu{
    public static void main(String[] args) {
		Scanner sc =new Scanner(System.in);
		int a=sc.nextInt();
		int b=sc.nextInt();
		int c=sc.nextInt();
		if(a>b){
			if(b>c){
				System.out.println(c+" "+b+" "+a);
			}
			else{
				if(a>c){
				    System.out.println(b+" "+c+" "+a);
				}else{
					System.out.println(b+" "+a+" "+c);
				}
			}
		}else{
			if(b>c){
				System.out.println(c+" "+b+" "+a);
			}
			else{
				if(a>c){
				    System.out.println(b+" "+c+" "+a);
				}else{
					System.out.println(b+" "+a+" "+c);
				}
			}
		}
      }
}

2.

import java.util.Scanner;

public class PaiXu{
   public static void main(String[] args) {
	Scanner sc =new Scanner(System.in);
	int a=sc.nextInt();
	int b=sc.nextInt();
	int c=sc.nextInt();
	int t=0;
	if(a>b){
		t=a;
		a=b;
		b=t;
	}
	if(b>c){
		t=b;b=c;c=t;
	}
	if(a>b){
		t=a;a=b;b=t;
	}
		System.out.println(a+" "+b+" "+c);
   }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值