HDU 2717 Catch That Cow


Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11487    Accepted Submission(s): 3560


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 


题意:给一个农夫的坐标和奶牛的坐标   农夫可以走的路径有三种  x-1,x+1,2*x;(不过这题没说农夫的坐标一定小于奶牛的,试了一下考虑不考虑都能A)
             是一道简单的搜索bfs,才做没往搜索想,一直想着暴力  还是做的题少学得算法少 不管做什么题开始总想暴力 根本想不到用什么算法  只有仔细思考才能看出来

代码:
         
#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 100005
using namespace std;
int n,m;
int d[200005];
int bfs(int n,int m)
{
    queue<int>q;
    q.push(n);
    d[n]=0;
    while(!q.empty())
    {
        int p=q.front();
        q.pop();
        if(p==m)
        {
            break;
        }
        for(int i=0; i<3; i++)
        {
            int nx;
            if(i==0)
            {
                nx=p+1;
            }
            if(i==1)
            {
               nx=p-1;
            }
            if(i==2)
            {
                 nx=p*2;
            }
            if(nx>=0&&nx<=INF&&d[nx]==INF)
            {
                q.push(nx);
                d[nx]=d[p]+1;
            }
        }
    }
    return d[m];
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
          for(int i=0;i<=INF;i++)
          {
              d[i]=INF;
          }
           int ans= bfs(n,m);
            printf("%d\n",ans);
    }
}

     
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值