HDU2717

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

思路:每一步有三种走法,对每一步进行bfs

(这题数据量不算太大,不用进行特殊处理也可以AC,但是我在后退一步的地方认为后退一步小于K/2的情况不用讨论,实际上有可能先回退几步然后在多次乘2得到最小值)

 

#include<cstdio>
#include<string.h>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#include<set>
#include<algorithm>
using namespace std;
#define INF 1<<28
static const int MAX = 200050;
int N, K;
int cnt[MAX];
int visit[MAX];

void bfs()
{
    queue<int> Q;
    Q.push(N);
    cnt[N] = 0;

    while (!Q.empty())
    {
        int q = Q.front(); Q.pop();//printf("%d %d\n", q, cnt[q]);
        visit[q] = 1;

        if (q + 1 <= K)
        {
            cnt[q + 1] = min(cnt[q + 1], cnt[q] + 1);
            if (visit[q + 1] == 0)
            {
                visit[q + 1] = 1;
                Q.push(q + 1);
            }
        }
        if (q - 1 >= 0) //条件改为q - 1 >= K/2会WA,因为有可能先回退再乘2
        {
            cnt[q - 1] = min(cnt[q - 1], cnt[q] + 1);
            if (visit[q - 1] == 0)
            {
                visit[q - 1] = 1;
                Q.push(q - 1);
            }
        }
        if (q * 2 <= K || q * 2 - K <= K - q)
        {
            cnt[q * 2] = min(cnt[q * 2], cnt[q] + 1);
            if (visit[q * 2] == 0)
            {
                visit[q * 2] = 1;
                Q.push(q * 2);
            }
        }
    }
}

int main()
{
    while (scanf("%d %d", &N, &K) != EOF)
    {
        int l = max(K, N);
        for (int i = 0; i < 2 * l + 1; i++)
            cnt[i] = INF;
        memset(visit, 0, sizeof(visit));
        bfs();
        printf("%d\n", cnt[K]);
    }
    return 0;
}




 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值