算法day07

1.UVA 10327 Flip Sort
Sorting in computer science is an important part. Almost every problem can be solved effeciently if sorted data are found. There are some excellent sorting algorithm which has already acheived the lower bound nlgn. In this problem we will also discuss about a new sorting approach. In this approach only one operation ( Flip ) is available and that is you can exchange two adjacent terms. If you think a while, you will see that it is always possible to sort a set of numbers in this way.
The Problem
A set of integers will be given. Now using the above approach we want to sort the numbers in ascending order. You have to find out the minimum number of flips required. Such as to sort “1 2 3” we need no flip operation whether to sort “2 3 1” we need at least 2 flip operations.
The Input
The input will start with a positive integer N ( N<=1000 ). In next few lines there will be N integers. Input will be terminated by EOF.
The Output
For each data set print “Minimum exchange operations : M” where M is the minimum flip operations required to perform sorting. Use a seperate line for each case.
Sample Input
3
1 2 3
3
2 3 1
Sample Output
Minimum exchange operations : 0
Minimum exchange operations : 2
代码:

#include <stdio.h>
#include <iostream>
using namespace std;

int main()
{
    int a[100],n,flag,ans,i;
    ans=0;
    cin>>n;
    while(!cin.eof()) //输入以EOF结束
    {
        flag=0;
        for(i=1;i<=n;i++)
            cin>>a[i];
        for(i=1;i<n;i++)
            if(a[i]>a[i+1])
        {
            swap(a[i],a[i+1]);
            ans++;
        }
        cout<<"MInimum exchange operations :"<<ans<<endl;
        cin>>n;
    }


    return 0;
}

Tips:
1.输入以EOF(end of file)结束,
win首先在最后一行结束后输入ENTER键,再输入ctrl+z,再输入时ENTER键即可。
Linux首先在最后一行结束后输入ENTER键,再输入ctrl+d,再输入时ENTER键即可。
2.
a.getchar

     c = getchar();//读入一个字符。
    if(c == EOF)break;//如果遇到EOF则退出循环,即结束输入。

b.scanf

    ret = scanf("%d",&c);//读入一个整型值。
    if(ret == EOF)break;//如果遇到EOF则退出循环,即结束输入。注意判断的是返回值,而不是读入的变量。

c.gets

    if(gets(s) == NULL) break;// 当gets返回NULL时代表遇到EOF,结束输入。

d.cin

     while(!cin.eof()) //输入以EOF结束
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值