A Simple Math Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 70 Accepted Submission(s): 39
Total Submission(s): 70 Accepted Submission(s): 39
Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions: X+Y=a Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
Sample Input
6 8 798 10780
Sample Output
No Solution 308 490
Source
2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)
这是大连区域赛上的D题,当时是我队友做的,现在重现赛上写一下。
话说最近一直看别人的代码,好久没写代码了,T T。
思路:
由题意可知:
lcm(x,y)=b;
因为 x*y =gcd(x,y)*lcm(x,y);
所以 x*y =gcd(x,y)*b;
因为 gcd(a,b)=gcd(x,y);
所以 x*y=b*gcd(a,b);
联立 x+y=a;
解个方程就行 ;
代码:
这是大连区域赛上的D题,当时是我队友做的,现在重现赛上写一下。
话说最近一直看别人的代码,好久没写代码了,T T。
思路:
由题意可知:
lcm(x,y)=b;
因为 x*y =gcd(x,y)*lcm(x,y);
所以 x*y =gcd(x,y)*b;
因为 gcd(a,b)=gcd(x,y);
所以 x*y=b*gcd(a,b);
联立 x+y=a;
解个方程就行 ;
代码:
#include <cstdio>
#include <cstring>
#include <cmath>
int gcd (int m,int n){
int flag;
while(n>0){
flag=m%n;
m=n;
n=flag;
}
return m;
}
int main (){
int a,b;
while(scanf("%d%d",&a,&b)!=EOF){
int i,j;
int c=gcd(a,b);
int x,y;
int delta= a*a-4*b*c;
if(delta<0){
printf("No Solution\n");
continue;
}
int flag= sqrt(delta);
if(flag*flag!=delta||(a-flag)%2!=0){
printf("No Solution\n");
continue;
}
x=(1*a-sqrt(delta))/2;
y=a-x;
printf("%d %d\n",x<y?x:y,x<y?y:x);
}
return 0;
}