HDU 5974 A Simple Math Problem(数论)

题目链接

A Simple Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 833    Accepted Submission(s): 291


Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
 

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

Sample Input
  
  
6 8 798 10780
 

Sample Output
  
  
No Solution 308 490
 

Source
 


参考博客链接

题意:

给出a和b,让你求出X和Y,使得X + Y = a    lcm(x,y) = b

题解:

令gcd(x,y) = g;

g * k1 = x;

g * k2 = y;

因为g 是最大公约数,那么k1与k2 必互质!

=>   g*k1*k2 = b

=>   g*k1 + g * k2 = a;

所以k1 * k2 = b / g;

k1 + k2 = a/g;

因为k1与k2 互质!

所以k1 * k2 和 k1 + k2 也一定互质(一个新学的知识点= = )

所以a/g 与b/g也互质!

那么g 就是gcd(a,b);

所以我们得出一个结论:   gcd(x,y) == gcd(a,b);

所以k1 + k2 与 k1 * k2都是已知的了,解一元二次方程即可!


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
#include<stack>
#include<cmath>
using namespace std;
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define pb push_back
#define fi first
#define se second
typedef vector<int> VI;
typedef long long ll;
typedef pair<int,int> PII;
const int inf=0x3fffffff;
const ll mod=1000000007;
const int maxn=20+10;
int gcd(int a,int b)
{
    return b==0? a:gcd(b,a%b);
}
int main()
{
    int a,b;
    while(~scanf("%d%d",&a,&b))
    {
        int g=gcd(a,b);
        a/=g,b/=g;
        int c=a*a-4*b;
        if(c<0)
        {
            puts("No Solution");
            continue;
        }
        int d=(int)sqrt(c);
        if(d*d!=c)
        {
            puts("No Solution");
            continue;
        }
        
        printf("%d %d\n",g*(a-d)/2,g*(a+d)/2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值