A multiplication game

Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input
Each line of input contains one integer number n.

Output
For each line of input output one line either
Stan wins.
or
Ollie wins.
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

题意:两个人轮流乘数字,从1开始,谁先乘到大于等于n为胜。数字从2-9里面选。
思路:这道题我是通过模拟找规律做的, 虽然说是2-9的选择,但是可以直接用2和9来概括选择,也就是说如果数比较小但在范围之外,为了不让对方赢,一定会选择2作乘数,而当数在范围之内了,就会选择9作乘数赢取游戏。 那么我们要做的就是找到这些范围,也就是临界点了。
列一段数据:
2-9 : Stan wins
10-18 : Ollie wins.
19-162 : Stan wins
163-324 : Ollie wins. ….
这样就很明确了, 因为乘数顺序的原因,Stan 最大值乘以2就是下一个临界点, 而Ollie的临界点乘以9是下一个临界点。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cmath>
using namespace std;
int a[100];
int main()
{
  int n, j = 1;
  long long int i = 9;
  while(i < 4294967295)
  {
      a[j++] = i;
      if(j%2==0)
        i*=2;
      else
        i*=9;
  }
  while(cin >> n)
  {
      for(i = 0; i < j; i++)
      {
          if(n == a[i])
          {
              if(i%2 == 0)
                cout << "Ollie wins." << endl;
              else
                cout << "Stan wins." << endl;
              break;
          }
          if(n > a[i] && n <= a[i+1])
          {
              if(i%2 == 0)
                cout << "Stan wins." << endl;
              else
                cout << "Ollie wins." << endl;
              break;
          }
      }
  }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值