博弈——A Multiplication Game(打表找规律)

18 篇文章 0 订阅

博弈——A Multiplication Game(打表找规律)

题目链接:
HDU - 1517

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

题目大意

两个人玩游戏,Stan先手,p 初始为 1,他们每次可以选择 2 ~ 9 之间的任意一个数与 p 相乘,当所得的数大于或等于 n 时,则获胜。

分析

可以先找找规律
0 ~ 9 Stan wins.
10 ~ 9 * 2 Ollie wins.
19 ~ 9 * 2 * 9 Stan wins.

从上面我们可以看出,必胜者总会乘以9,让自己尽量大去取到 n,必败者总会乘以 2,来尽量阻止必胜者取到 n,所以我们可以将 n 不断地除以 18,直到其小于 18 为止,这样,我们就可以判断谁输谁赢了。

#include<bits/stdc++.h>
using namespace std;

int main()
{
	double n;
	while(cin>>n){
		while(n>18){
			n/=18;
		}
		if(n<=9){
			cout<<"Stan wins."<<endl;
		}
		else{
			cout<<"Ollie wins."<<endl;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值