poj3734(Blocks)快速幂+组合数学

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6


题意:n个方块排成一列,每块可以涂成红蓝绿黄四种颜色,问红色方块和绿色方块个数同时为偶数的方案有多少种?


题解:设ai, bi, ci分别表示到第i块为止红绿都是偶数、红绿有一个是偶数、红绿都是奇数方案数,那么

ai+1 = 2ai + bi

bi+1 = 2ai + 2bi + 2ci

ci+1 = bi + 2ci

写成矩阵形式后用快速幂即可求解


#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;

typedef vector<int> vec;
typedef vector<vec> mat;
const int Mod = 10007;

mat mul(mat& a, mat& b)
{
    mat c(3, vec(3));
    for (int i = 0; i < 3; ++i)
        for (int k = 0; k < 3; ++k)
            for (int j = 0; j < 3; ++j)
                c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % Mod;
    return c;

}

mat pow(mat& a, int n)
{
    mat b(3, vec(3));
    for (int i = 0; i < 3; ++i)
        b[i][i] = 1;
    while (n > 0)
    {
        if (n&1)
            b = mul(b, a);
        a = mul(a, a);
        n >>= 1;
    }
    return b;
}

int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        int n;
        scanf("%d", &n);
        mat a(3, vec(3));
        a[0][0] = 2; a[0][1] = 1; a[0][2] = 0;
        a[1][0] = 2; a[1][1] = 2; a[1][2] = 2;
        a[2][0] = 0; a[2][1] = 1; a[2][2] = 2;
        a = pow(a, n);
        printf("%d\n", a[0][0]);
    }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

算法码上来

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值