How Many Answers Are Wrong HDU - 3038

T and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 
Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 
Output
A single line with a integer denotes how many answers are wrong.
Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1
Sample Output
1

思路:这个题其实题意十分的简单,给你从a到b一个区间,再给你这个区间的和,让你判断有多少组数据与上面给出的数据存在矛盾。这是一个分类在并查集中的题目,但是我却一头雾水,并不知道怎么与并查集联系起来,然后在kuangbin的博客看到了题解(kuangbin的题解)。他是将a到b的和看做了b比a-1大x。然后用并查集的方法解决。

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <cstdio>
#define MAXN 200010
#define INF 1 << 27

using namespace std;

int rank1[MAXN];
int par[MAXN];
int val[MAXN];
int ans;

void init(int n){
    for(int i = 1; i <= n; ++i){
        rank1[i] = 0;
        par[i] = i;
        val[i] = 0;
    }
}

int find(int x) {
    if (par[x] == x)
        return x;
    int tmp = find(par[x]);
    val[x] += val[par[x]]; //val[x]加上其祖先的大小
    return par[x] = tmp;
}

void unite(int x, int y, int num) {
    int x1 = find(x); // 在这里,find函数的作用是找到 x的祖先,即x比哪个数大
    int y1 = find(y);
    if (y1 == x1) {
        if (val[y] - val[x] != num) //如果它们对应的数不同,就比较看是否存在矛盾
            ans++;
        return;
    } else {
        par[y1] = x1;
        val[y1] = val[x] - val[y] + num; //进行数据的更新
    }
}

int main(){
    int n, m;
    while(~scanf("%d%d", &n, &m)){
        int x, y, z;
        init(n);
        ans = 0;
        for(int i = 0; i < m; ++i){
            scanf("%d%d%d", &x, &y, &z);
            unite(x - 1, y, z);
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值