本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number
,其中 X
是输入。最后在一行中输出结果:The average of K numbers is Y
,其中 K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined
替换 Y
。如果 K
为 1,则输出 The average of 1 number is Y
。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
结尾无空行
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
结尾无空行
输入样例 2:
2
aaa -9999
结尾无空行
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
结尾无空行
#include<bits/stdc++.h>
#include<stdlib.h>
using namespace std;
int main(){
int n,count=0;
double sum=0;
cin>>n;
for(int i=0;i<n;i++){
int flag=0,xaioshudian=0,fuhao=0;
string a;
cin>>a;
for(int j=0;j<a.size();j++){
if(a[j]>='0'&&a[j]<='9');
else if(a[j]=='.'){
xaioshudian++;
string s=a.substr(j+1);
if(xaioshudian>1||s.size()>2)flag=1;
}
else if(a[j]=='-'){//测试点2也包括这个
fuhao++;
if(fuhao>1)flag=1;
}
else flag=1;
}
if(flag==0);
double temp=atof(a.c_str());
if(fabs(temp)>1000||flag==1) cout<<"ERROR: "<<a<<" is not a legal number"<<endl;
else{sum+=temp;count++;}
}
if(count==0)printf("The average of 0 numbers is Undefined");
else if(count==1)printf("The average of 1 number is %.2f",sum);//测试点2
else printf("The average of %d numbers is %.2f",count,sum*1.0/count);
return 0;
}
c的解法
#include<stdio.h>
#include<string.h>
int main(){
int n,flag=0;
char a[50],b[50];//a存储输入的字符,b存储格式化后的字符串
scanf("%d",&n);
int i,j,count=0;
double temp,sum=0;
for(i=0;i<n;i++){
scanf("%s",&a);
sscanf(a,"%lf",&temp);//从一个字符串中读进与指定格式相符的数据
sprintf(b,"%.2lf",temp);//字符串格式化命令,主要功能是把格式化的数据写入某个字符串中
for(j=0;j<strlen(a);j++)
if(a[j]!=b[j])flag=1;
if(flag==1||temp<-1000||temp>1000)
{printf("ERROR: %s is not a legal number\n",a);
flag=0;}
else {
sum+=temp;
count++;
}
}
if(count==0)
printf("The average of 0 numbers is Undefined");
else if(count==1)
printf("The average of %d number is %.2f",count,sum/count);//测试点2 好坑啊。。
else
printf("The average of %d numbers is %.2f",count,sum/count);
return 0;
}