首字母变大写

首字母变大写

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 107   Accepted Submission(s) : 56
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

输入一个英文句子,将每个单词的第一个字母改成大写字母。

Input

输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。

Output

请输出按照要求改写后的英文句子。

Sample Input

i like acm
i want to get an accepted

Sample Output

I Like Acm
I Want To Get An Accepted
//正确的写法 
#include<stdio.h>
#include<string.h>
int main()
{
    int i,n,len;
    char str[110];
    while(gets(str))//输入的是 i like acm整个的字符串,而如果用scanf的话会默认输入三个字符串i,like,acm.
    {
    	len=strlen(str);
    	for(i=0;i<len;i++)
    		if(i==0||str[i-1]==' ')//空格加引号
    		   str[i]=str[i]-32;//在ascII中小写字母减去32(不用加引号)得对应的大写字母
        printf("%s\n",str);
    }
	return 0;
}
 
//用scanf错误的写法 
#include<stdio.h>
#include<string.h>
int main()
{
	int n,i;
	char a[1000];
	while(~scanf("%s",a))
	{	
		n=strlen(a);
		for(i=0;i<n;i++)
		{
			if(i==0)
			a[i]=a[i]-32; 
			if(a[i]==' ') 
			a[i+1]=a[i+1]-32;
		}
		printf("%s\n",a);	
	}
	return 0;
}

错误输出为
I
Like
Acm
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值