HDU 2120--Ice_cream's world I【并查集, 判断环的个数】

50 篇文章 0 订阅
4 篇文章 0 订阅

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 846    Accepted Submission(s): 493


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
  
  
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
3
 
 
题意:在一个王国里,建立很多瞭望塔,瞭望塔之间连接有围墙。给出瞭望塔个数n,各个塔之间的围墙数m。接着给出m组A  ,B塔(塔是从0开始到n-1的)
表示A  B之间有围墙连接,问这些哨塔,围墙把土地分割成了几个部分

思路:找出环的个数即是土地的块数,每当一组数根节点相同时它们就可能已经和其他的数构成了环,它们有可能是环的开始和结束

<span style="color:#000000;">#include<cstdio>
int per[1010];
int count=0;
void asd()//重要:把每一元素的根节点都设为它本身;
{
for(int i=0;i<1010;i++)/ 
{
	per[i]=i;
}
}
int find(int x)
 {
 int r,i;
r=x;
while(r!=per[r])
{
	r=per[r];
}
return r;
}
void join(int a,int b)//每一次它们根节点相同时(也就是说a能到b)都能构成一个环; 
{
	int fa,fb;
	fa=find(a);
	fb=find(b);
	if(fa!=fb)
	per[fa]=fb;
	else
	count++;
}
int main()
{
	int n,m,i,a,b;
	while(~scanf("%d",&n))
	{
		asd();
		scanf("%d",&m);
		count=0; 
		while(m--)
		{
				scanf("%d %d",&a,&b);
				join(a,b);
		}
		printf("%d\n",count);
	}
	return 0;
}</span>


 

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值