Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13000 Accepted Submission(s): 5822
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2 100 -4
Sample Output
1.6152 No solution!
Author
Redow
#include<stdio.h>
#include<math.h>
double fun(double x)
{
return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
int n;
double y,l,r,mid;
scanf("%d",&n);
while(n--)
{
scanf("%lf",&y);
l=0.0;
r=100.0;
if(y<fun(l)||y>fun(r))//因为其为递增序列则fun(l)为最小值,fun(r)为最大值
{
printf("No solution!\n");
continue;//停止while循环进行下一次while循环
}
while(r-l>1e-10)//二分法模板:死记!!!!!!
{
mid=(r+l)/2.0;
if(fun(mid)<y)
l=mid+1e-10;
else
r=mid-1e-10;
}
printf("%.4lf\n",mid);
}
return 0;
}