1005 hdoj Number Sequence (java函数格式)

28 篇文章 0 订阅
2 篇文章 0 订阅

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 145944    Accepted Submission(s): 35462



Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1004  1021  1019  1003

题目的意思很明白,就是给你表达式让你推出给的数,运用函数的递归,我把java函数温习了一遍,在敲了遍,希望有所提高。为了防止忘记留下函数语法知识java 函数
奉上新鲜出炉的代码
<pre name="code" class="java">import java.util.*;
import java.math.*;
import java.io.*;
public class Main {
public static int fun(int x,int y,int z)
{
	if(z==1||z==2)
	{
		return 1;
	}
	else
	{
	 z = (x * fun(x, y, z - 1) + y * fun(x, y, z - 2)) %7;//递归
	return z;
	}
	
}
	public static void main(String[] args) {
		// TODO Auto-generated method stub
    Scanner in = new Scanner(System.in);
    while(in.hasNext())
    {
    	int a,b,c;
    	a=in.nextInt();
    	b=in.nextInt();
    	c=in.nextInt();
    	if(a==0&&b==0&&c==0)
    	break;
    	else
    	{
    		System.out.println(fun(a,b,c%49));//防止超时%49和%7效果一样·,但%49不会超时
    	}
    }
    

	}

}

 
 


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值