hdu 1372 Knight Moves

hdu 1372
  Knight Moves
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64d

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 
 

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.". 
 

Sample Input

     
     
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

Sample Output

     
     
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.




#include <stdio.h>
#include <queue>
#include <algorithm>
#include <string.h>
#define N 200
using namespace std;

typedef struct{
   int num, step;
   char le;
}lct;
queue <lct> q;
int vis[N][N];

int main()
{
    lct start, finish;
    while(scanf("%c",&start.le)!=EOF)   //¶à×éÊý¾Ý
    {
        int p = 0, nstep = 0;
        memset(vis,0,sizeof(vis));
        while(!q.empty()) q.pop();

        scanf("%d %c%d", &start.num, &finish.le, &finish.num);

        if (start.le == finish.le && start.num == finish.num)
            printf("To get from %c%d to %c%d takes 0 knight moves.\n",start.le ,start.num, finish.le, finish.num);
        else{
        start.step = 0;
        vis[start.num][start.le] = 1;
        q.push(start);
        while (!q.empty())
        {
            lct tmp = q.front();
            q.pop();
            lct a[8];//a1, a2, a3, a4, a5, a6, a7, a8;
            a[1].num = a[6].num =  tmp.num + 1;
            a[2].num = a[5].num =  tmp.num - 1;
            a[0].num = a[7].num =  tmp.num + 2;
            a[4].num = a[3].num =  tmp.num - 2;
            a[0].le = a[3].le = tmp.le + 1;
            a[1].le = a[2].le = tmp.le + 2;
            a[4].le = a[7].le = tmp.le - 1;
            a[5].le = a[6].le = tmp.le - 2;
            //printf("%c%d\n",a[1].le,a[1].num);
            for (int i = 0; i < 8; i++)
                a[i].step = tmp.step + 1;
            for (int i = 0; i < 8; i++)
            {
                if (a[i].num > 0 && a[i].num < 9 && a[i].le >= 'a' && a[i].le <= 'h' && vis[a[i].num][a[i].le] == 0)
                    {
                        vis[a[i].num][a[i].le ] = 1;
                        //printf("%c %d %d\n", a[i].le, a[i].num, a[i].step);
                        q.push(a[i]);
                    }
                if (a[i].num == finish.num && a[i].le == finish.le)
                   {
                         p = 1;
                         nstep = a[i].step;
                         break;
                   }
            }
            if (p == 1)
            {
                printf("To get from %c%d to %c%d takes %d knight moves.\n",start.le ,start.num, finish.le, finish.num, nstep);
                break;
            }
        }
        }


    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值