Regular polygon HDU - 6055

                  

                            Regular polygon 

    On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.


Input

The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)

Output

For each case, output a number means how many different regular polygon these points can make.


Sample Input

4
0 0
0 1
1 0
1 1
6
0 0
0 1
1 0
1 1
2 0
2 1

Sample Output

1
2

 由于给出的点都是整数而且要组合成正多边形,只可能组合出正方形,接下来枚举正方形就行了

#include<bits/stdc++.h>
using namespace std;
int aim[500][500];
struct Point
{
    int x,y;
}p[555];
int solve(Point a,Point b)
{
    int x=a.x-b.x;
    int y=a.y-b.y;
    int ans=0;
    /*
    判断要找的点是否越界以及是否存在
    */
    if(a.x+y>=0&&a.y-x>=0&&b.x+y>=0&&b.y-x>=0&&aim[a.x+y][a.y-x]&&aim[b.x+y][b.y-x])
        ans++;///边以下做一个正方形
    if(a.x-y>=0&&a.y+x>=0&&b.x-y>=0&&b.y+x>=0&&aim[a.x-y][a.y+x]&&aim[b.x-y][b.y+x])
        ans++;///边以上做一个正方形
    return ans;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(aim,0,sizeof(aim));
        for(int i=0;i<n;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            a+=200;///正方形的下标必须大于等于零
            b+=200;
            p[i].x=a;
            p[i].y=b;
            aim[a][b]=1;
        }
        int ans=0;
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                ans+=solve(p[i],p[j]);
            }
        }
        printf("%d\n",ans/4);///正方形有四条边
    }                        ///任意两点都能构成一个正方形
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值