2017 Multi-University Training Contest - Team 3 1003 Kanade's sum

27 篇文章 0 订阅

Kanade's sum

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2109    Accepted Submission(s): 862


Problem Description
Give you an array A[1..n] of length n .

Let f(l,r,k) be the k-th largest element of A[l..r] .

Specially , f(l,r,k)=0 if rl+1<k .

Give you k , you need to calculate nl=1nr=lf(l,r,k)

There are T test cases.

1T10

kmin(n,80)

A[1..n] is a permutation of [1..n]

n5105
 

Input
There is only one integer T on first line.

For each test case,there are only two integers n , k on first line,and the second line consists of n integers which means the array A[1..n]
 

Output
For each test case,output an integer, which means the answer.
 

Sample Input
  
  
1 5 2 1 2 3 4 5
 

Sample Output
  
  
30
 
一开始先维护一个满的链表,然后从小到大删除,每次算完一个数,就在链表里面删除,算x的时候,保证删除的数都比x小,都可以用来算贡献。i和pre[i]和nxt[i]的距离就是小于当前的数的数目+1

#include <bits/stdc++.h>
using namespace std;
const int N = 5e5 + 10;
typedef long long LL;

int pre[N], nxt[N], v[N], pos[N], n, k;
LL a[N], b[N];
LL solve(int x)
{
    int c1 = 0, c2 = 0;
    for (int i = x; i && c1 <= k; i = pre[i])
    {
        a[++c1] = i - pre[i];
    }
    for (int i = x; i <= n && c2 <= k; i = nxt[i])
    {
        b[++c2] = nxt[i] - i;
    }
    LL ans = 0;
    for (int i = 1; i <= c1; i++)
        if (k - i + 1 <= c2 && k - i + 1 >= 1)
        {
            ans += a[i] * b[k - i + 1];
        }
    return ans;
}
void del(int x)
{
    pre[nxt[x]] = pre[x];
    nxt[pre[x]] = nxt[x];
}
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &k);
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &v[i]), pos[v[i]] = i;
        }
        for (int i = 0; i <= n + 1; i++)
        {
            pre[i] = i - 1, nxt[i] = i + 1;
        }
        pre[0] = 0;
        nxt[n + 1] = n + 1;
        LL ans = 0;
        for (int i = 1; i <= n; i++)
        {
            ans += solve(pos[i]) * i;
            del(pos[i]);
        }
        printf("%lld\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值