Chessboard
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1331 Accepted Submission(s): 553
Total Submission(s): 1331 Accepted Submission(s): 553
Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.
Input
There are multiple test cases in the input file.
First line contain the number of cases T ( T≤10000 ).
In the next T lines contain T cases , Each case has two integers n and k. ( 1≤n,k≤100 )
First line contain the number of cases T ( T≤10000 ).
In the next T lines contain T cases , Each case has two integers n and k. ( 1≤n,k≤100 )
Output
Print the maximum number of chessboard squares tiled.
Sample Input
2 6 3 5 3
Sample Output
36 24
///用 k × 1 的小矩形覆盖一个 n × n 的正方形棋盘,
///问正方形棋盘最多能被覆盖多少。
///规律就是:如果n<k,肯定不行。
///定义mod=n%k;
///如果(mod<=k/2),结果为:n*n-mod*mod;
///否则结果为:n*n-(k-mod)*(k-mod);
///问正方形棋盘最多能被覆盖多少。
///规律就是:如果n<k,肯定不行。
///定义mod=n%k;
///如果(mod<=k/2),结果为:n*n-mod*mod;
///否则结果为:n*n-(k-mod)*(k-mod);
#include <bits/stdc++.h>
#define _ ios_base::sync_with_stdio(0);cin.tie(0);
using namespace std;
int main()
{
_
int t;
cin >> t;
while (t--)
{
int n, k;
cin >> n >> k;
if (n < k)
{
cout << "0" << endl;
continue;
}
int mod = n % k;
if (mod <= k / 2)
{
cout << n*n - mod*mod << endl;
}
else
{
cout << n*n - (k - mod)*(k - mod) << endl;
}
}
return 0;
}