2017 Multi-University Training Contest - Team 9 1008 Numbers

27 篇文章 0 订阅
27 篇文章 0 订阅

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 289    Accepted Submission(s): 148


Problem Description
zk has n numbers a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number (ai+aj) . These new numbers could make up a new sequence b1b 2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each ai is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6
 

题目大意:

如果我们现在有一个数组A【】,那么我们每一次拿出两个数A【i】和A【j】,使得B【cnt++】=A【i】+A【j】,主人公不小心把两个数组并到了一起,并且还是从小到大保证递增的,问我们数组A【】的信息。输出其大小和元素。


思路:

考虑到A【】数组的最大长度是500.那么我们暴力去搞就行。

最小的数肯定属于A【】,理所当然倒数第二小的数也肯定属于A【】,那么我们就可以根据这两个数确定一个B【】肯定有的,那么我们将全部序列中去掉这几个数之后,肯定接下来那个最小的数也属于A【】;依次类推

时间复杂度O(n+500^2);


#include<stdio.h>
#include<string.h>
#include<map>
using namespace std;

int a[125255];
int output[125255];
int main()
{
    int n;
    while (~scanf("%d", &n))
    {
        int ans = 0;
        for (int i = 1; i <= n; i++)
        {
            if (i + (i) * (i - 1) / 2 == n)
            {
                ans = i;
                break;
            }
        }


        map<int, int>s;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
        }
        int cnt = 0;
        for (int i = 1; i <= n; i++)
        {
            if (s[a[i]] > 0)
            {
                s[a[i]]--;
            }
            else
            {
                for (int j = 0; j < cnt; j++)
                {
                    s[a[i] + output[j]]++;
                }
                output[cnt++] = a[i];
            }
        }


        printf("%d\n", ans);
        for (int i = 0; i < cnt; i++)
        {
            if (i > 0)
            {
                printf(" ");
            }
            printf("%d", output[i]);
        }
        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值