1030. Travel Plan

1030. Travel Plan (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40
题解:
#include <iostream>
#include <vector>
#include <algorithm>
#include <deque>
using namespace std;

#define  maxlen 10000000

class road
{
public:
	int city;
	int length;
	int cost;
};

class city
{
public:
	vector<road> aroad;
	int path;
	int allcost;
	bool finded;
	int father_city;
	city():path(maxlen),finded(false),allcost(maxlen),father_city(maxlen){}
};

bool cmp(road a, road b)
{
	if(a.length==b.length)
		return a.cost<b.cost;
	return a.length<b.length;
}

void shortest(deque<int> &que,vector<city> &acity,int c_end)
{
	int now=que[0];
	int i;
	for(i=0;i<acity[now].aroad.size();i++)//分析与que[0]相邻的点
	{
		road adj_city=acity[now].aroad[i];
		if(acity[adj_city.city].finded)
			continue;
		que.push_back(adj_city.city);
		if(acity[adj_city.city].path>acity[now].path+adj_city.length
			||(acity[adj_city.city].path==acity[now].path+adj_city.length&&acity[adj_city.city].allcost>acity[now].allcost+adj_city.cost))//修改花费
		{
			acity[adj_city.city].path=acity[now].path+adj_city.length;
			acity[adj_city.city].allcost=acity[now].allcost+adj_city.cost;
			acity[adj_city.city].father_city=now;//父城市修改
		}
	}
	acity[now].finded=true;
	que.pop_front();
	if(que.empty()||acity[c_end].finded)//已经遍历所有的,或者到达目标点
		return;
	shortest(que,acity,c_end);
}


int main()
{
	int n,m;//n cities and m roads
	int c_begin,c_end;
	cin>>n>>m>>c_begin>>c_end;
	vector<city> acity(n);
	int i,tmp1,tmp2,tmpdis,tmpcost;
	road tmp;
	for(i=0;i<m;i++)
	{
		cin>>tmp1>>tmp2>>tmpdis>>tmpcost;//City1 City2 Distance Cost
		tmp.city=tmp2;tmp.length=tmpdis;tmp.cost=tmpcost;
		acity[tmp1].aroad.push_back(tmp);
		tmp.city=tmp1;
		acity[tmp2].aroad.push_back(tmp);
	}
	for(i=0;i<n;i++)
		sort(acity[i].aroad.begin(),acity[i].aroad.end(),cmp);
	deque<int> que;
	acity[c_begin].path=0;
	acity[c_begin].allcost=0;
	que.push_back(c_begin);
	shortest(que,acity,c_end);
	deque<int> result;
	int now=c_end;
	result.push_front(now);//先将目标城市push,以防起始城==目标城
	now=acity[now].father_city;
	while(now!=c_begin)
	{
		result.push_front(now);
		now=acity[now].father_city;
	}
	result.push_front(c_begin);
	for(i=0;i<result.size();i++)
		cout<<result[i]<<" ";
	cout<<acity[c_end].path<<" "<<acity[c_end].allcost<<endl;
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
该信息出现的原因是因为在映射文件中找不到com.travel.travel.mapper.UserMapper.findAll这个绑定的语句。根据引用提供的信息,你需要在Java的配置文件中创建一个包,将你的mapper映射文件放进去,并且要注意包名与你的mapper接口的包名要一致。另外,根据引用提供的信息,你还需要在pom.xml文件中加入一些配置,以确保资源和代码文件被正确加载。最后,根据引用提供的信息,你可以下载一个提供者和消费者模块的示例代码进行学习,并在http://127.0.0.1:8083/user/getUser这个地址上进行简单的调用。这些步骤和配置可以帮助你解决Invalid bound statement (not found)的问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [Invalid bound statement (not found): com.itheima.mapper.userMapper.SelectAll](https://blog.csdn.net/weixin_64773406/article/details/127726908)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *3* [plan_project.zip](https://download.csdn.net/download/weixin_39846786/12233758)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值