PAT 1020. Tree Traversals

1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.


Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2


题解:

#include <iostream>
#include <vector>
#include <deque>
#include <algorithm>
using namespace std;

class node
{
public:
	int data;
	node* left;
	node* right;
	node(int v):data(v),left(NULL),right(NULL){}
};

node* maketree(node* root,vector<int> &postorder,vector<int> inoder)//建树
{
	if(inoder.empty())
		return NULL;
	int value=postorder.back();
	postorder.pop_back();
	root=new node(value);
	vector<int>::iterator itr,mid;
	vector<int> left_in;
	vector<int> right_in;
	mid=find(inoder.begin(),inoder.end(),value);//找到postorder最后一个在inorder中的位子
	for(itr=inoder.begin();itr<mid;itr++)//左子树
		left_in.push_back(*itr);
	for(itr=mid+1;itr<inoder.end();itr++)//右子树
		right_in.push_back(*itr);
	root->right=maketree(root->right,postorder,right_in);
	root->left=maketree(root->left,postorder,left_in);
	return root;
}

void levelprint(deque<node> &result)//层序打印
{
	if(result[0].left!=NULL)//将即将打印的node的左右子树依次push_back()
		result.push_back(*result[0].left);
	if(result[0].right!=NULL)
		result.push_back(*result[0].right);
	if(result.size()==1)
	{
		cout<<result[0].data;
		return;                    //打印完毕
	}
	cout<<result[0].data<<" ";
	result.pop_front();
	levelprint(result);
	return;
}

int main()
{
	int n;
	cin>>n;	
	vector<int> postorder(n);
	vector<int> inorder(n);
	node* root=NULL;
	int i;
	for(i=0;i<n;i++)
		cin>>postorder[i];
	for(i=0;i<n;i++)
		cin>>inorder[i];
	root=maketree(root,postorder,inorder);
	deque<node> result;//创建打印队列
	result.push_back(*root);
	levelprint(result);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值