Problem E : Online Judge

Problem E : Online Judge

From: HDU, 1073
Submit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user’s result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return “Accepted”, else if the only differences between the two files are spaces(’ ‘), tabs(’\t’), or enters(’\n’), the Judge System should return “Presentation Error”, else the system will return “Wrong Answer”.

Given the data of correct output file and the data of user’s result file, your task is to determine which result the Judge System will return.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user’s result file. Both of them are starts with a single line contains a string “START” and end with a single line contains a string “END”, these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END

Sample Output:
Presentation Error
Presentation Error
Wrong Answer
Presentation Error

AC代码

#include<iostream>
#include<vector>
using namespace std;
int main()
{
    int t;
    cin>>t;
    string z[4];
    string x;
    cin.get();
    while(t--)
    {
       z[0].clear(),z[1].clear();//负责存储最原始的数据
       z[2].clear(),z[3].clear();//负责存储那些去除符号的数据
       for(int i=0;i<2;i++)
       {
           getline(cin,x);//读取start
           for(;;)
           {
               getline(cin,x);//读取一行
               if(x!="END")
                   z[i]+=x+'\n';//把数据存到字符串中
               else
                   break;
           }
           for(int j=0;j<z[i].length();j++)
               if(z[i][j]!='\t'&&z[i][j]!=' '&&z[i][j]!='\n')
                   z[i+2]+=z[i][j];
       }
       if(z[2]!=z[3])//判断去除后是否相等
           cout<<"Wrong Answer"<<endl;//不等为WA
       else if(z[0]!=z[1])//判断整体是否相等
           cout<<"Presentation Error"<<endl;//不等为PE
       else
           cout<<"Accepted"<<endl;//全等为AC
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值