【水题-字符串】HDU 1073 Online Judge


Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".
Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
  
  
4 START 1 + 2 = 3 END START 1+2=3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 4 END START 1 + 2 = 3 END START 1 + 2 = 3 END

Sample Output
  
  
Presentation Error Presentation Error Wrong Answer Presentation Error

简单的说这个题就是模拟OJ系统进行测评的过程,输出测评结果(AC、WA或PE)。那么,如何去测评两组数据呢?完全匹配当然就是AC啦,那PE和WA如何发现呢?我们可以先将输入输入的两组数据去掉'\n','\t' 和' ',得到新的两组数据,那么这两组数据如果不是完全匹配的,结果一定是WA。如果这两组匹配了,去掉 '\n','\t' 和' '前的不完全匹配则是PE。如果去掉前的两组数据完全匹配,则是AC。

#include <iostream>
using namespace std;

int main()
{
    int t;
    string s;
    string ans[4];//使用string存储数据
    cin >> t;
    cin.get();//这里是为了读掉多余的'\n',不然会出错
    while (t--)
    {
        ans[0].clear(), ans[1].clear();//清空
        ans[2].clear(), ans[3].clear();
        for (int i = 0; i < 2; i++)
        {
            getline(cin, s);//读取START
            for (;;)
            {
                getline(cin, s);//读取一行
                if (s != "END")//判断是不是END
                    ans[i] += s + '\n';//加到数据里
                else
                    break;
            }
            for (int j = 0; j < ans[i].size(); j++)//计算出去掉换行、制表和空格之后的数据
                if (ans[i][j] != '\n' && ans[i][j] != '\t' && ans[i][j] != ' ')
                    ans[i + 2] += ans[i][j];
        }
        if (ans[2] != ans[3])
            cout << "Wrong Answer" << endl;
        else if (ans[0] != ans[1])
            cout << "Presentation Error" << endl;
        else
            cout << "Accepted" << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值