Phone List

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1671

Phone List

Time Limit: 3000/1000   Memory Limit: 32768/32768 K
Total Submission(s): 17056    Accepted Submission(s): 5739

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题目大意:这和题目的意思是说一个电话号码的前缀不能是另一个电话,如果是前缀输出“NO”,不是前缀输出“YES”。
解题思路:我仔细分析了一下可能出现的情况,可能出现的是下面测试的几种情况:
输入:

3
2
911
91
2
911
91
2

于是,在代码中用c和x分别来标记是否正在操作的node是上一个字符串的尾节点和是否新申请node。分析了c与x各为0或1的时候是不是前缀。

这里写图片描述

由分析结果来看,只要是当一个字符串的为节点就是前缀,其他情况都是不是前缀。

参考代码:

#include<iostream>
#include<algorithm>
#include<memory.h>
#include<string.h>
using namespace std;
struct node{
    int Count;
    bool EndS;
    node* next[10];
    node(){
        Count = 0;
        EndS = 0;
        for (int i = 0; i < 10; i++)
            next[i] = 0;
    }
};
bool insert(char *a,node* root){
    int L = strlen(a);
    bool c = 0;
    node* d = root;
    bool x = 0;
    for (int i = 0; i < L; i++)
    {
        if (d->next[a[i] - '0'] == NULL)
        {
            d->next[a[i] - '0'] = new node;
            x = 1;
        }
        if (d->EndS != 1)
        {
            d = d->next[a[i] - '0'];
            d->Count = a[i] - '0';
        }
        else {
            c = 1;
            return 0;
        }
    }
    d->EndS = 1;
    if (c == 0 && x == 1)
        return 1;
    else return 0;
}
void del(node* p){
    if (p == NULL)
        return;
    int i = 0;
    for (i = 0; i < 10; i++)
    {
        del(p->next[i]);
    }
    delete p;
}
int main()
{
    int x, y;
    cin >> x;
    char a[15];
    node *root;
    while (x--)
    {   
        root = new node;
        bool c = 0;
        int cite = 0;
        cin >> y;
        while (y--)
        {
            cin >> a;
            c = insert(a,root);
            if (c == 0)
                cite = 1;
        }
        if (cite != 1)
            cout << "YES" << endl;
        else cout << "NO" << endl;
        del(root);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值