概率dp——B - Aeroplane chess HDU - 4405

博客目录

返回二级目录——kaugnbin概率dp习题集

一、原题

题目传送门

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 

Input

There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 

Sample Input

2 0
8 3
2 4
4 5
7 8
0 0

Sample Output

1.1667
2.3441

三、分析:

期望倒着算,概率正着算

  • 定义状态:   dp[i]表示 从i走到大于等于n的格子的期望
  • 则状态转移:  dp[i]= dp[i+k]/6+1;
  • ps:               概率dp事实上只有动态,没有规划。

四、AC代码:

#include<bits/stdc++.h>
using namespace std;
/*
  qq1176611589
*/
typedef struct node
{
	int x,y;
}node;
bool operator<(node a,node b)
{
	return a.x<b.x;
}
vector<node>book;
double dp[100000+10];//至少多余出6个空间 
int main()
{
	int n,i,j,k;
	node t;
	int m;
	while(cin>>n>>m,n||m)
	{
		book.clear();
		for(i=0;i<m;i++)
		{
			scanf("%d %d",&t.x,&t.y);
			book.push_back(t);
		}
		sort(book.begin(),book.end());
		j=n-1;
		dp[n]=0;	//
		for(i=m-1;i>=0;i--)
		{
			for(;j>book[i].x;j--)
			{
				for(k=1;k<=6;k++)
					dp[j]+=dp[j+k]/6;
				dp[j]+=1;
			}
			dp[j]=dp[book[i].y];
			j--;
		}
		for(;j>=0;j--)
		{
			for(k=1;k<=6;k++)
				dp[j]+=dp[j+k]/6;
			dp[j]+=1;
		}
		printf("%.4lf\n",dp[0]);
		memset(dp,0,sizeof dp);
	}
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值